summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-08-10 14:37:54 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-08-10 14:37:54 +0200
commit6463578384d9101ca3f0072ca3a19ba7865f4e94 (patch)
tree1692a1f2b1ae22106c934323abbe27a0dbf2637a /gnu/packages/linux.scm
parent5d6ff1e8282f31c3590d8dacfb90f175d7b16e72 (diff)
downloadguix-patches-6463578384d9101ca3f0072ca3a19ba7865f4e94.tar
guix-patches-6463578384d9101ca3f0072ca3a19ba7865f4e94.tar.gz
gnu: Remove duplicated linux-libre packages.
Remove linux-libre-arm-generic-5.7 and linux-libre-arm64-generic-5.7 that are respectively duplicating linux-libre-arm-generic and linux-libre-arm64-generic. Fixes: https://issues.guix.gnu.org/42794. * gnu/packages/linux.scm (linux-libre-arm-generic-5.7, linux-libre-arm64-generic-5.7): Remove them.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm24
1 files changed, 0 insertions, 24 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f04cd999f4..a2d6d384ee 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -917,18 +917,6 @@ It has been modified to remove all non-free binary blobs.")
("CONFIG_RTC_DRV_RK808" . #t))
%default-extra-linux-options)))
-(define-public linux-libre-arm-generic-5.7
- (make-linux-libre* linux-libre-5.7-version
- linux-libre-5.7-source
- '("armhf-linux")
- #:defconfig "multi_v7_defconfig"
- #:extra-version "arm-generic"
- #:extra-options
- (append
- `(;; needed to fix the RTC on rockchip platforms
- ("CONFIG_RTC_DRV_RK808" . #t))
- %default-extra-linux-options)))
-
(define-public linux-libre-arm-veyron
(deprecated-package "linux-libre-arm-veyron" linux-libre-arm-generic))
@@ -979,18 +967,6 @@ It has been modified to remove all non-free binary blobs.")
("CONFIG_RTC_DRV_RK808" . #t))
%default-extra-linux-options)))
-(define-public linux-libre-arm64-generic-5.7
- (make-linux-libre* linux-libre-5.7-version
- linux-libre-5.7-source
- '("aarch64-linux")
- #:defconfig "defconfig"
- #:extra-version "arm64-generic"
- #:extra-options
- (append
- `(;; needed to fix the RTC on rockchip platforms
- ("CONFIG_RTC_DRV_RK808" . #t))
- %default-extra-linux-options)))
-
(define-public linux-libre-riscv64-generic
(make-linux-libre* linux-libre-version
linux-libre-source