summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-02-18 14:59:08 +0100
committerMarius Bakke <marius@gnu.org>2022-02-19 10:43:22 +0100
commit57bfc7233b3e28a48c5c61938a2f533d2dac5356 (patch)
treef0aedd9a171e2590f8fc4a0e0da2f795f51073df /gnu/packages/linux.scm
parent6e5d21942509ff29249f98ff0e0f3eabd7341144 (diff)
downloadguix-patches-57bfc7233b3e28a48c5c61938a2f533d2dac5356.tar
guix-patches-57bfc7233b3e28a48c5c61938a2f533d2dac5356.tar.gz
gnu: efivar: Update to 38.
* gnu/packages/linux.scm (efivar): Update to 38. [source](snippet, modules, patches): Remove. [native-inputs]: Add MANDOC. (efibootmgr)[source](modules, snippet): New fields. * gnu/packages/patches/efivar-gcc-compat.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm28
1 files changed, 13 insertions, 15 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a534622847..d4ae8c5c76 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6708,25 +6708,15 @@ under OpenGL graphics workloads.")
(define-public efivar
(package
(name "efivar")
- (version "37")
+ (version "38")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/rhboot/" name
"/releases/download/" version "/" name
"-" version ".tar.bz2"))
- (patches (search-patches "efivar-gcc-compat.patch"))
(sha256
(base32
- "17vvfivhsrszh7q39b6npjsrhrhsjf1cmmcpp3xrh6wh7ywzwrrw"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Compile everything within a single LTO partition
- ;; to work around ordering issues in the code. Try
- ;; removing this for versions > 37.
- (substitute* "Make.defaults"
- (("-flto")
- "-flto -flto-partition=one"))))))
+ "0jaka7b4lccswjqiv4liclkj6w78gildg7vd6dnw3wf595pfs67h"))))
(build-system gnu-build-system)
(arguments
`(;; Tests require a UEFI system and is not detected in the chroot.
@@ -6739,7 +6729,7 @@ under OpenGL graphics workloads.")
(modify-phases %standard-phases
(delete 'configure))))
(native-inputs
- (list pkg-config))
+ (list mandoc pkg-config))
(inputs
(list popt))
(home-page "https://github.com/rhboot/efivar")
@@ -6761,10 +6751,18 @@ interface to the variable facility of UEFI boot firmware.")
(file-name (git-file-name name version))
(sha256
(base32 "1niicijxg59rsmiw3rsjwy4bvi1n42dynvm01lnp9haixdzdpq03"))
- (patches (search-patches "efibootmgr-remove-extra-decl.patch"))))
+ (patches (search-patches "efibootmgr-remove-extra-decl.patch"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Cast the first argument to the correct type. Extracted
+ ;; from upstream commit e8ce9fecebd15adb4.
+ (substitute* '("src/efibootdump.c" "src/efibootmgr.c")
+ (("efidp_format_device_path\\(text_path,")
+ "efidp_format_device_path((unsigned char *)text_path,"))))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ;no tests
+ '(#:tests? #f ;no tests
#:make-flags (list (string-append "prefix=" %output)
(string-append "libdir=" %output "/lib")
;; EFIDIR denotes a subdirectory relative to the