summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2020-03-23 02:42:56 +0000
committerVagrant Cascadian <vagrant@debian.org>2020-03-22 20:55:37 -0700
commit37f8c50cdc2e99189c74999319f3a1854d419546 (patch)
treef8fa8d0e03f24278f52a9ae0c82eff547691a0cc /gnu/packages/linux.scm
parent4ef89d884db8dae3aa300e36a3ad89def374e012 (diff)
downloadguix-patches-37f8c50cdc2e99189c74999319f3a1854d419546.tar
guix-patches-37f8c50cdc2e99189c74999319f3a1854d419546.tar.gz
gnu: linux-libre-arm-veyron: Deprecate package.
* gnu/packages/linux (linux-libre-arm-veyron): Mark as deprecated package. (kernel-config-veyron): Remove obsolete function. * gnu/system/examples/asus-c201.tmpl: Update to use linux-libre-arm-generic. * gnu/packages/aux-files/linux-libre/5.4-arm-veyron.conf: Delete file. * Makefile.am (AUX_FILES): Update accordingly.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm15
1 files changed, 1 insertions, 14 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c39c411e3d..4e1f48de19 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -566,15 +566,6 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
(file (string-append "linux-libre/" name)))
(search-auxiliary-file file)))
-;; FIXME: merge into kernel-config
-(define* (kernel-config-veyron arch #:key variant)
- "Return the absolute file name of the Linux-Libre build configuration file
-for ARCH and optionally VARIANT, or #f if there is no such configuration."
- (let* ((name (string-append (if variant (string-append variant "-") "")
- (if (string=? "i386" arch) "i686" arch) "-veyron.conf"))
- (file (string-append "linux-libre/" name)))
- (search-auxiliary-file file)))
-
(define %default-extra-linux-options
`(;; Some very mild hardening.
("CONFIG_SECURITY_DMESG_RESTRICT" . #t)
@@ -845,11 +836,7 @@ It has been modified to remove all non-free binary blobs.")
;;;
(define-public linux-libre-arm-veyron
- (make-linux-libre* linux-libre-version
- linux-libre-source
- '("armhf-linux")
- #:configuration-file kernel-config-veyron
- #:extra-version "arm-veyron"))
+ (deprecated-package "linux-libre-arm-veyron" linux-libre-arm-generic))
(define-public linux-libre-arm-generic
(make-linux-libre* linux-libre-version