summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-15 01:26:59 +0200
committerMarius Bakke <marius@gnu.org>2020-05-26 22:32:49 +0200
commit312d9a332053118ca002f4d1e3aa43ea588e593c (patch)
treed5fe96d0ad7d38678c8a9e382a2f653bb115f076 /gnu/packages/linux.scm
parentddcfc467968d8367e62cb24cbc9e89bb5af0fe6d (diff)
downloadguix-patches-312d9a332053118ca002f4d1e3aa43ea588e593c.tar
guix-patches-312d9a332053118ca002f4d1e3aa43ea588e593c.tar.gz
gnu: kmod: Disable tests in 'Makefile.in' instead of 'Makefile.am'.
This avoids a build failure because the package was bootstrapped with an older version of Automake. By substituting the .in file we avoid triggering the Autoconf machinery. * gnu/packages/linux.scm (kmod)[arguments]: Change the 'disable-tests' phase to substitute "Makefile.in" instead of "Makefile.am". [native-inputs]: Remove AUTOMAKE and AUTOCONF.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index fb1ed8d5b7..3fd902e340 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2950,9 +2950,7 @@ to use Linux' inotify mechanism, which allows file accesses to be monitored.")
(patches (search-patches "kmod-module-directory.patch"))))
(build-system gnu-build-system)
(native-inputs
- `(("automake" ,automake)
- ("autoconf" ,autoconf)
- ("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)))
(inputs
`(("xz" ,xz)
("zlib" ,zlib)))
@@ -2964,7 +2962,7 @@ to use Linux' inotify mechanism, which allows file accesses to be monitored.")
(add-after 'unpack 'disable-tests
(lambda _
;; XXX: These tests need '--sysconfdir=/etc' to pass.
- (substitute* "Makefile.am"
+ (substitute* "Makefile.in"
(("testsuite/test-modprobe") "")
(("testsuite/test-depmod") "")
(("testsuite/test-blacklist") ""))