summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2021-12-21 22:20:27 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-12-23 18:13:00 +0100
commit18576c4db42c5f16e75d91f759b0927ad6281caa (patch)
tree31c048adebd73c031d3df8784da720f4df2852b5 /gnu/packages/linux.scm
parent00cf011a831fe3b3e6f623af1994ed2ec98855d0 (diff)
downloadguix-patches-18576c4db42c5f16e75d91f759b0927ad6281caa.tar
guix-patches-18576c4db42c5f16e75d91f759b0927ad6281caa.tar.gz
gnu: Add watchdogd.
* gnu/packages/linux.scm (watchdogd): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index bab88c7d88..11b89ed9a7 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -141,6 +141,7 @@
#:use-module (gnu packages slang)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages texinfo)
+ #:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
#:use-module (gnu packages valgrind)
#:use-module (gnu packages video)
@@ -4123,6 +4124,29 @@ dm-thin, dm-cache and dm-era device-mapper targets.")
(home-page "https://github.com/jthornber/thin-provisioning-tools")
(license license:gpl3+)))
+(define-public watchdogd
+ (package
+ (name "watchdogd")
+ (version "3.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/troglobit/watchdogd")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "05f7igavzimfgbh39fflbkmpya12r854n03dkyimwashcqwchx8f"))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf automake libtool pkg-config))
+ (inputs (list libconfuse libite libuev))
+ (synopsis "Advanced system & process supervisor for Linux")
+ (description "This package provides an advanced monitor of critical system
+resources, supervises the heartbeat of processes, records deadline
+transgressions, and initiates a controlled reset if needed")
+ (home-page "https://troglobit.com/projects/watchdogd/")
+ (license license:isc)))
+
(define-public wireless-tools
(package
(name "wireless-tools")