summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-06-28 18:44:03 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-06-28 18:45:37 +0200
commit184fac5927b4327f434dfb426d5626bc21c4f31f (patch)
tree92ac497888325c4dde226543c5d8747f7b954328 /gnu/packages/linux.scm
parent370ab47095ea89af12c4e5b29766f7cae9f3eab3 (diff)
downloadguix-patches-184fac5927b4327f434dfb426d5626bc21c4f31f.tar
guix-patches-184fac5927b4327f434dfb426d5626bc21c4f31f.tar.gz
gnu: Add librem-ec-acpi-linux-module.
* gnu/packages/linux.scm (librem-ec-acpi-linux-module): New public variable.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 00c9485d34..7011319504 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1182,6 +1182,32 @@ It grants direct and undocumented access to your hardware that may cause damage
and should be used with caution, especially on untested models.")
(license license:gpl3+))) ; see README.md (no licence headers)
+(define-public librem-ec-acpi-linux-module
+ (package
+ (name "librem-ec-acpi-linux-module")
+ (version "0.9.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://source.puri.sm/nicole.faerber/librem-ec-acpi-dkms")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qnbfj60i8nn2ahgj2zp5ixd79bb0wl1ld36x3igws2f3c0f5pfi"))))
+ (build-system linux-module-build-system)
+ (arguments
+ `(#:tests? #f)) ; no test suite
+ (home-page "https://source.puri.sm/nicole.faerber/librem-ec-acpi-dkms")
+ (synopsis "Linux kernel module to control the Librem Embedded Controller")
+ (description
+ "This is the Linux kernel @acronym{ACPI, Advanced Configuration and Power
+Interface} platform driver for the @acronym{EC, Embedded Controller} firmware
+on Purism Librem laptop computers. It allows user-space control over the
+battery charging thresholds, keyboard backlight, fans and thermal monitors,
+and the notification, WiFi, and Bluetooth LED.")
+ (license license:gpl2+)))
+
(define-public rtl8812au-aircrack-ng-linux-module
(let ((commit "059e06a51be025fde5b2bec6565540b3d9981b0b")
(revision "4"))