summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2020-03-07 03:53:38 -0500
committerJan Nieuwenhuizen <janneke@gnu.org>2020-03-14 09:24:15 +0100
commit11a5ffba7327250ebe7b67c777204e49858310bb (patch)
tree18e4b3cf0d6cd8d53b9f1f4e557f07f3ef602569 /gnu/packages/linux.scm
parent4889be6ceb794d8c535d90df007e012ab7c2161e (diff)
downloadguix-patches-11a5ffba7327250ebe7b67c777204e49858310bb.tar
guix-patches-11a5ffba7327250ebe7b67c777204e49858310bb.tar.gz
gnu: coreutils: Remove libcap dependency for the Hurd.
* gnu/packages/linux.scm (libcap)[supported-systems]: Remove the Hurd. * gnu/packages/base.scm (coreutils)[inputs]: Include libcap only for supported systems. Fixes building on the Hurd.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e9f261e859..977f448b56 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -42,6 +42,7 @@
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2020 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2068,6 +2069,7 @@ configuration (iptunnel, ipmaddr).")
(assoc-ref %outputs "out"))
"RAISE_SETFCAP=no")))
(native-inputs `(("perl" ,perl)))
+ (supported-systems (delete "i586-gnu" %supported-systems))
(home-page "https://sites.google.com/site/fullycapable/")
(synopsis "Library for working with POSIX capabilities")
(description