summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-08-28 16:47:39 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-08-30 08:57:56 +0200
commit0168c65de4ec9f25d5de76998474bedfd2baa7a0 (patch)
tree0d68f79ddbb52bee8c8bfba81ed61c7e34d04fb4 /gnu/packages/linux.scm
parent5192bead3266784d9bc98cc7a0522cf7580f175c (diff)
downloadguix-patches-0168c65de4ec9f25d5de76998474bedfd2baa7a0.tar
guix-patches-0168c65de4ec9f25d5de76998474bedfd2baa7a0.tar.gz
gnu: proot: Don't ask to run tests when cross-compiling.
* gnu/packages/linux.scm (proot)[arguments]{#:tests?}: When cross-compiling, set to #false. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d8f1f6912e..b5a2737730 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7687,9 +7687,9 @@ Text-based output formats: CSV, XML, Netfilter's LOG, Netfilter's conntrack
;; Disable the test suite on armhf-linux, as there are too many
;; failures to keep track of (see for example:
;; https://github.com/proot-me/proot/issues/286).
- `(#:tests? ,(not (string-prefix? "armhf"
- (or (%current-target-system)
- (%current-system))))
+ `(#:tests? ,(not (or (%current-target-system)
+ (string-prefix? "armhf"
+ (or (%current-system)))))
#:make-flags '("-C" "src")
#:phases (modify-phases %standard-phases
(add-after 'unpack 'patch-sources