summaryrefslogtreecommitdiff
path: root/gnu/packages/linphone.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-29 03:19:09 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-03-29 16:45:44 -0400
commit6aaa8269b82d50e43405847a479ffaeb0b569fa5 (patch)
tree6041a5b6bffab0fe02a4a5c6c823d9163fa75d9b /gnu/packages/linphone.scm
parent7162e5b88208d00188dd9c7b22e0fcde2871fb55 (diff)
downloadguix-patches-6aaa8269b82d50e43405847a479ffaeb0b569fa5.tar
guix-patches-6aaa8269b82d50e43405847a479ffaeb0b569fa5.tar.gz
gnu: linphone-desktop: Fix linphone accounts functionality.
The Linphone accounts were not able to do TLS authentication against the Linphone servers, and multiple plugins used by the Linphone accounts were not loaded. This change should fix this. * gnu/packages/linphone.scm (linphone-desktop)[phases](post-install): Modify phase. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/linphone.scm')
-rw-r--r--gnu/packages/linphone.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index 2107560aa0..deda49a4bc 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -839,10 +839,14 @@ and video calls or instant messaging capabilities to an application.")
;; Remove unnecessary Qt configuration file.
(delete-file (string-append out "/bin/qt.conf"))
;; Not using the FHS exposes an issue where the client
- ;; refers to its own "share" directory, which lacks files
+ ;; refers to its own directories, which lacks files
;; installed by the dependencies.
+ (symlink (string-append liblinphone "/lib")
+ (string-append out "/lib"))
(symlink (string-append liblinphone "/share/sounds")
(string-append out "/share/sounds"))
+ (symlink (string-append liblinphone "/share/linphone/rootca.pem")
+ (string-append out "/share/linphone/rootca.pem"))
(mkdir-p (dirname grammar-dest))
(symlink (string-append liblinphone "/share/belr/grammars")
grammar-dest)))))))