summaryrefslogtreecommitdiff
path: root/gnu/packages/linphone.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-16 12:40:05 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-03-29 01:17:13 -0400
commit23a96055fb1c952d9b182b4f2dbd53e7ac25deba (patch)
treea93282f304300232289b6c0e75b582fbd189f7fb /gnu/packages/linphone.scm
parentabc1418786df47816a00c68e90c770d9692a2bb7 (diff)
downloadguix-patches-23a96055fb1c952d9b182b4f2dbd53e7ac25deba.tar
guix-patches-23a96055fb1c952d9b182b4f2dbd53e7ac25deba.tar.gz
gnu: belle-sip: Update to 4.4.34.
* gnu/packages/linphone.scm (belle-sip)[source]: Switch to git repository. [version]: Update to 4.4.34. [home-page]: Update. [license]: Update to GPLv3+. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/linphone.scm')
-rw-r--r--gnu/packages/linphone.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index 0da9e02b4c..6f7634ecdb 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -480,15 +480,16 @@ including both ARM and x86.")
(define-public belle-sip
(package
(name "belle-sip")
- (version "1.6.3")
+ (version "4.4.34")
(source
(origin
- (method url-fetch)
- (uri
- (string-append "https://www.linphone.org/releases/sources/" name
- "/" name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://git.linphone.org/belle-sip")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0s55kggmgxap54dkw5856bgk4xg7yvbzialpxnjm0zhpic3hff1z"))))
+ (base32 "1kknnlczq7dpqaj1dwxvy092dzrqjy11ndkv90rqwmdryigkjk6z"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; Requires network access
@@ -513,8 +514,8 @@ including both ARM and x86.")
(description "Belle-sip is a modern library implementing SIP transport,
transaction and dialog layers. It is written in C, with an object-oriented
API. It also comprises a simple HTTP/HTTPS client implementation.")
- (home-page "https://gitlab.linphone.org/BC/public/belle-sip")
- (license license:gpl2+)))
+ (home-page "https://linphone.org/technical-corner/belle-sip")
+ (license license:gpl3+)))
(define-public mediastreamer2
(package