summaryrefslogtreecommitdiff
path: root/gnu/packages/linphone.scm
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-09-03 20:44:07 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-09-04 08:20:22 +0200
commit0c7f478e83c0218e4c3d78aa3b5c0cdc9a604741 (patch)
treee659660d56a7028b6a4c1dec0efc0b8923c9cba3 /gnu/packages/linphone.scm
parentb9a7fa817a65f74a68c5a5104d9ec861fb778800 (diff)
downloadguix-patches-0c7f478e83c0218e4c3d78aa3b5c0cdc9a604741.tar
guix-patches-0c7f478e83c0218e4c3d78aa3b5c0cdc9a604741.tar.gz
gnu: liblinphone: Add installation of man pages.
* gnu/packages/linphone.scm (liblinphone)[arguments]: Add phase 'install-man-pages. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/linphone.scm')
-rw-r--r--gnu/packages/linphone.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index 14da150ced..a6492893c8 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -458,6 +458,14 @@ including media capture, encoding and decoding, and rendering.")
(delete-file-recursively
(string-append out "/share/doc/linphone-" ,version))
#t)))
+ (add-after 'install 'install-man-pages
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (man (string-append out "/share/man/man1")))
+ (for-each (lambda (file)
+ (install-file file man))
+ (find-files ".." ".*.1$"))
+ #t)))
(add-after 'separate-outputs 'glib-or-gtk-compile-schemas
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
(add-after 'glib-or-gtk-compile-schemas 'glib-or-gtk-wrap