summaryrefslogtreecommitdiff
path: root/gnu/packages/linphone.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-15 22:11:02 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-03-26 23:03:52 -0400
commit05e0bd07d4fcfd082a8095150a86ceacb4635b7c (patch)
tree6485c93116967e95514fa78640fd3feff75a2a70 /gnu/packages/linphone.scm
parent53dd99bc0b2e23c5463b4cb95546fd438a72d229 (diff)
downloadguix-patches-05e0bd07d4fcfd082a8095150a86ceacb4635b7c.tar
guix-patches-05e0bd07d4fcfd082a8095150a86ceacb4635b7c.tar.gz
gnu: bcg729: Enable tests and update home page, license.
* gnu/packages/linphone.scm (bcg729)[source]: Remove '.git' suffix from URL. [tests?]: Remove argument. [configure-flags]: Enable tests. [phases]{copy-inputs}: New phase. {check}: Override. [native-inputs]: Add perl, test-patterns and unzip. [home-page]: Update. [license]: Upgrade to GPLv3+. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/linphone.scm')
-rw-r--r--gnu/packages/linphone.scm56
1 files changed, 50 insertions, 6 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index 382b3a912b..19b50170d2 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -243,24 +243,68 @@ tracks in one file. ")
(origin
(method git-fetch)
(uri (git-reference
- (url "git://git.linphone.org/bcg729.git")
+ (url "git://git.linphone.org/bcg729")
(commit version)))
(file-name (git-file-name name version))
(sha256
(base32 "1hal6b3w6f8y5r1wa0xzj8sj2jjndypaxyw62q50p63garp2h739"))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f ; No test target
- #:configure-flags
- (list "-DENABLE_STATIC=NO"))) ; Not required
+ `(#:configure-flags (list "-DENABLE_STATIC=NO"
+ "-DENABLE_TESTS=YES")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'copy-inputs
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((test-patterns (assoc-ref inputs "test-patterns"))
+ (dest (string-append "test/bcg729-patterns.zip")))
+ (copy-recursively test-patterns dest))))
+ (replace 'check
+ (lambda _
+ (with-directory-excursion "test"
+ (invoke "unzip" "bcg729-patterns.zip")
+ (for-each
+ (lambda (test-name)
+ (invoke "./testCampaign" "-s" test-name))
+ (list "fixedCodebookSearch"
+ "postProcessing"
+ "adaptativeCodebookSearch"
+ "computeLP"
+ "computeAdaptativeCodebookGain"
+ "postFilter"
+ "decoder"
+ "LPSynthesisFilter"
+ "decodeLSP"
+ ;; "encoder"
+ ;; "LSPQuantization"
+ "preProcessing"
+ "decodeFixedCodeVector"
+ "CNGdecoder"
+ ;; "LP2LSPConversion"
+ "gainQuantization"
+ "findOpenLoopPitchDelay"
+ "decodeGains"
+ "computeWeightedSpeech"
+ "interpolateqLSPAndConvert2LP"
+ "decodeAdaptativeCodeVector"))))))))
+ (native-inputs
+ `(("perl" ,perl)
+ ("test-patterns"
+ ,(origin
+ (method url-fetch)
+ (uri (string-append "http://www.belledonne-communications.com/"
+ "bc-downloads/bcg729-patterns.zip"))
+ (sha256
+ (base32 "1kivarhh3izrl9sg0szs6x6pbq2ap0y6xsraw0gbgspi4gnfihrh"))))
+ ("unzip" ,unzip)))
(synopsis "Belledonne Communications G729 Codec")
(description "BcG729 is an implementation of both encoder and decoder of
the ITU G729 speech codec. The library written in C 99 is fully portable and
can be executed on many platforms including both ARM and x86 processors. It
supports concurrent channels encoding and decoding for multi call application
such as conferencing.")
- (home-page "https://gitlab.linphone.org/BC/public/belcard")
- (license license:gpl2+)))
+ (home-page "https://linphone.org/technical-corner/bcg729")
+ (license license:gpl3+)))
(define-public ortp
(package