summaryrefslogtreecommitdiff
path: root/gnu/packages/lighting.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/lighting.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/lighting.scm')
-rw-r--r--gnu/packages/lighting.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/lighting.scm b/gnu/packages/lighting.scm
index 4718795a8a..5850da84d8 100644
--- a/gnu/packages/lighting.scm
+++ b/gnu/packages/lighting.scm
@@ -54,15 +54,14 @@
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(native-inputs
- `(("bison" ,bison)
- ("cppunit" ,cppunit)
- ("flex" ,flex)
- ("pkg-config" ,pkg-config)
-
- ;; For git repository bootstrapping.
- ("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)))
+ (list bison
+ cppunit
+ flex
+ pkg-config
+ ;; For git repository bootstrapping.
+ autoconf
+ automake
+ libtool))
(inputs
`(("libftdi" ,libftdi)
("libmicrohttpd" ,libmicrohttpd)
@@ -70,7 +69,7 @@
("libuuid" ,util-linux "lib")
("zlib" ,zlib)))
(propagated-inputs
- `(("protobuf" ,protobuf))) ; for pkg-config --libs libola
+ (list protobuf)) ; for pkg-config --libs libola
(arguments
`( ;; G++ >= 4.8 macro expansion tracking requires lots of memory, causing
;; build to fail on low memory systems. We disable that with the