summaryrefslogtreecommitdiff
path: root/gnu/packages/lighting.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-16 12:08:37 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-16 12:16:07 +0200
commit784e7d7ae9840b4d38379e587dd181a9490cd101 (patch)
tree6f949088512844e793a397da3aaa16833c9240e6 /gnu/packages/lighting.scm
parentf27a7e41568c0ae47b8c9a34c4f7e628e97d6c46 (diff)
downloadguix-patches-784e7d7ae9840b4d38379e587dd181a9490cd101.tar
guix-patches-784e7d7ae9840b4d38379e587dd181a9490cd101.tar.gz
gnu: ola: Build with libmicrohttpd 0.9.71.
* gnu/packages/lighting.scm (ola)[source]: Update to 0.10.7-0.5d88293. [source]: Use GIT-FETCH & GIT-FILE-NAME. Remove patch. [native-inputs]: Add autoconf, automake, and libtool. * gnu/packages/patches/ola-readdir-r.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/lighting.scm')
-rw-r--r--gnu/packages/lighting.scm88
1 files changed, 49 insertions, 39 deletions
diff --git a/gnu/packages/lighting.scm b/gnu/packages/lighting.scm
index 18110420de..027c08b4e9 100644
--- a/gnu/packages/lighting.scm
+++ b/gnu/packages/lighting.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
-;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -19,10 +19,11 @@
(define-module (gnu packages lighting)
#:use-module (guix build-system gnu)
- #:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages bison)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -35,46 +36,55 @@
#:use-module (gnu packages protobuf))
(define-public ola
- (package
- (name "ola")
- (version "0.10.7")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/OpenLightingProject/ola/releases/download/"
- version "/ola-" version ".tar.gz"))
- (patches (search-patches "ola-readdir-r.patch"))
- (sha256
- (base32
- "181imc9qkjm2m1iwrb5ixsckx893nc6qwjfzacsjlqp0jlnj8rca"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("bison" ,bison)
- ("cppunit" ,cppunit)
- ("flex" ,flex)
- ("pkg-config" ,pkg-config)))
- (inputs
- `(("libftdi" ,libftdi)
- ("libmicrohttpd" ,libmicrohttpd)
- ("libusb" ,libusb)
- ("libuuid" ,util-linux "lib")
- ("zlib" ,zlib)))
- (propagated-inputs
- ;; Ola 0.10.5 only supports protobuf 2.x, and building it with 3.x breaks.
- ;; XXX Remove protobuf-2 when it is no longer needed.
- `(("protobuf" ,protobuf-2))) ;; for pkg-config --libs libola
- (arguments
- `(;; G++ >= 4.8 macro expansion tracking requires lots of memory, causing
- ;; build to fail on low memory systems. We disable that with the
- ;; following configure flags.
- #:configure-flags (list "CXXFLAGS=-ftrack-macro-expansion=0")))
- (synopsis "Framework for controlling entertainment lighting equipment")
- (description "The Open Lighting Architecture is a framework for lighting
+ ;; Use a commit that allows building with libmicrohttpd 0.9.71.
+ ;; https://github.com/OpenLightingProject/ola/pull/1651
+ (let ((commit "5d882936436240b312b3836afd199587beaca840")
+ (revision "0"))
+ (package
+ (name "ola")
+ (version (git-version "0.10.7" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OpenLightingProject/ola")
+ (commit commit)))
+ (sha256
+ (base32 "1bhl3gvmvmnyrygfj13cibf2xirm285m8abjkaxq22hrqbsvab2m"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("bison" ,bison)
+ ("cppunit" ,cppunit)
+ ("flex" ,flex)
+ ("pkg-config" ,pkg-config)
+
+ ;; For git repository bootstrapping.
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (inputs
+ `(("libftdi" ,libftdi)
+ ("libmicrohttpd" ,libmicrohttpd)
+ ("libusb" ,libusb)
+ ("libuuid" ,util-linux "lib")
+ ("zlib" ,zlib)))
+ (propagated-inputs
+ ;; Ola 0.10.5 only supports protobuf 2.x, and building it with 3.x breaks.
+ ;; XXX Remove protobuf-2 when it is no longer needed.
+ `(("protobuf" ,protobuf-2))) ;; for pkg-config --libs libola
+ (arguments
+ `( ;; G++ >= 4.8 macro expansion tracking requires lots of memory, causing
+ ;; build to fail on low memory systems. We disable that with the
+ ;; following configure flags.
+ #:configure-flags (list "CXXFLAGS=-ftrack-macro-expansion=0")))
+ (synopsis "Framework for controlling entertainment lighting equipment")
+ (description "The Open Lighting Architecture is a framework for lighting
control information. It supports a range of protocols and over a dozen USB
devices. It can run as a standalone service, which is useful for converting
signals between protocols, or alternatively using the OLA API, it can be used
as the backend for lighting control software. OLA runs on many different
platforms including ARM, which makes it a perfect fit for low cost Ethernet to
DMX gateways.")
- (home-page "https://www.openlighting.org/ola")
- (license license:lgpl2.1+)))
+ (home-page "https://www.openlighting.org/ola")
+ (license license:lgpl2.1+))))