summaryrefslogtreecommitdiff
path: root/gnu/packages/license.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-01-28 01:41:35 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-02-24 20:01:29 +0300
commitf4e2d9ee6cf49ae7a9ff9a084517c274ea791955 (patch)
tree290157ab06b0e714d920b879efc6a90b7f7e96de /gnu/packages/license.scm
parent3787b7cba15cce88cc5fe7ee5431dff10c22cf66 (diff)
downloadguix-patches-f4e2d9ee6cf49ae7a9ff9a084517c274ea791955.tar
guix-patches-f4e2d9ee6cf49ae7a9ff9a084517c274ea791955.tar.gz
gnu: Add perl-string-copyright.
* gnu/packages/license.scm (perl-string-copyright): New public variable.
Diffstat (limited to 'gnu/packages/license.scm')
-rw-r--r--gnu/packages/license.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/license.scm b/gnu/packages/license.scm
index 39fbbc88c5..1cda21d6ed 100644
--- a/gnu/packages/license.scm
+++ b/gnu/packages/license.scm
@@ -55,3 +55,27 @@ expression patterns related to legal software licenses.
Regexp::Pattern is a convention for organizing reusable regex patterns.")
(license gpl3+)))
+
+(define-public perl-string-copyright
+ (package
+ (name "perl-string-copyright")
+ (version "0.003005")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/J/JO/JONASS/String-Copyright-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "12c6x4c10gr46ryc3dpwgfi6wggmgy4a1ls2hwhcpdm3wvzy5619"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-number-range" ,perl-number-range)))
+ (propagated-inputs
+ `(("perl-exporter-tiny" ,perl-exporter-tiny)))
+ (home-page "http://search.cpan.org/dist/String-Copyright/")
+ (synopsis "Representation of text-based copyright statements")
+ (description "String::Copyright Parses common styles of copyright
+statements and serializes in normalized format.")
+ (license gpl3+)))