summaryrefslogtreecommitdiff
path: root/gnu/packages/license.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-01-28 01:27:00 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-02-24 20:01:29 +0300
commitd5ee4342c0e62124a6efeb7da4c53c1f69c51d1e (patch)
tree9189ec8fbaa5e1fc7bc7d6751a63ca03d04a5914 /gnu/packages/license.scm
parent0f4d93903a73c1d32d6e05f4d4dc9d426b3ed248 (diff)
downloadguix-patches-d5ee4342c0e62124a6efeb7da4c53c1f69c51d1e.tar
guix-patches-d5ee4342c0e62124a6efeb7da4c53c1f69c51d1e.tar.gz
gnu: Add perl-regexp-pattern-license.
* gnu/packages/license.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add this.
Diffstat (limited to 'gnu/packages/license.scm')
-rw-r--r--gnu/packages/license.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/license.scm b/gnu/packages/license.scm
new file mode 100644
index 0000000000..39fbbc88c5
--- /dev/null
+++ b/gnu/packages/license.scm
@@ -0,0 +1,57 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages license)
+ #:use-module (guix licenses)
+ #:use-module (gnu packages)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system perl)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages perl-check))
+
+;;;
+;;; Please: Try to add new module packages in alphabetic order.
+;;;
+
+(define-public perl-regexp-pattern-license
+ (package
+ (name "perl-regexp-pattern-license")
+ (version "3.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/J/JO/JONASS/Regexp-Pattern-License-"
+ "v" version ".tar.gz"))
+ (sha256
+ (base32
+ "1479ismcgq1mx712yhw0qswb4z75spc81f9k621vfpkji0smpyk2"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-regexp-pattern" ,perl-regexp-pattern)
+ ("perl-test-exception" ,perl-test-exception)))
+ (propagated-inputs
+ `(("perl-strictures" ,perl-strictures-2)))
+ (home-page "http://search.cpan.org/dist/Regexp-Pattern-License/")
+ (synopsis "Regular expressions for legal licenses")
+ (description "Regexp::Pattern::License provides a hash of regular
+expression patterns related to legal software licenses.
+
+Regexp::Pattern is a convention for organizing reusable regex patterns.")
+ (license gpl3+)))