summaryrefslogtreecommitdiff
path: root/gnu/packages/libusb.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2020-03-13 20:34:14 +0000
committerVagrant Cascadian <vagrant@debian.org>2020-03-13 13:44:19 -0700
commitf08d654af697d3f52060ed505aa78e38cd8fe9da (patch)
treec93a7231a02ea2783c31ff7b1d1b6378a3a5ccc4 /gnu/packages/libusb.scm
parent79a48038579361689982a279564e0d4130918de7 (diff)
downloadguix-patches-f08d654af697d3f52060ed505aa78e38cd8fe9da.tar
guix-patches-f08d654af697d3f52060ed505aa78e38cd8fe9da.tar.gz
gnu: Add python-capablerobot-usbhub.
* gnu/packages/libusb (python-capablerobot-usbhub): New variable.
Diffstat (limited to 'gnu/packages/libusb.scm')
-rw-r--r--gnu/packages/libusb.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/libusb.scm b/gnu/packages/libusb.scm
index f41ed6b9bc..01c138cb4e 100644
--- a/gnu/packages/libusb.scm
+++ b/gnu/packages/libusb.scm
@@ -302,6 +302,47 @@ wrapper for accessing libusb-1.0.")
(define-public python2-pyusb
(package-with-python2 python-pyusb))
+(define-public python-capablerobot-usbhub
+ (package
+ (name "python-capablerobot-usbhub")
+ (version "0.2.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "capablerobot_usbhub" version))
+ (sha256
+ (base32
+ "1priic4iq2vn1rc711kzxwhxrwa508rkxrr193qdz2lw26kdhvix"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-udev-rules
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (mkdir-p (string-append out "/lib/udev/rules.d"))
+ (copy-file "50-capablerobot-usbhub.rules"
+ (string-append out
+ "/lib/udev/rules.d/"
+ "50-capablerobot-usbhub.rules"))
+ #t))))))
+ (propagated-inputs
+ `(("python-click" ,python-click)
+ ("python-construct" ,python-construct)
+ ("python-pyusb" ,python-pyusb)
+ ("python-pyyaml" ,python-pyyaml)))
+ (home-page
+ "https://github.com/CapableRobot/CapableRobot_USBHub_Driver")
+ (synopsis
+ "Host side driver for the Capable Robot Programmable USB Hub")
+ (description
+ "This package provides access to the internal state of the Capable Robot
+USB Hub, allowing you to monitor and control the Hub from an upstream
+computer. It also creates a transparent CircuitPython Bridge, allowing
+unmodified CircuitPython code to run on the host computer and interact with
+I2C and SPI devices attached to the USB Hub.")
+ (license license:expat)))
+
(define-public libplist
(package
(name "libplist")