summaryrefslogtreecommitdiff
path: root/gnu/packages/libusb.scm
diff options
context:
space:
mode:
authorTheodoros Foradis <theodoros.for@openmailbox.org>2016-10-28 20:36:05 +0300
committerDavid Craven <david@craven.ch>2016-10-30 02:03:04 +0200
commit3d74f12e63f7f94e2609b7bb028c3153df05c9bb (patch)
tree4d8e4d0c9b596219a7fe8a6eff6a2b3ce331478b /gnu/packages/libusb.scm
parent94f36a4f5e101dc7d4f65224b1d3f0abebe643af (diff)
downloadguix-patches-3d74f12e63f7f94e2609b7bb028c3153df05c9bb.tar
guix-patches-3d74f12e63f7f94e2609b7bb028c3153df05c9bb.tar.gz
gnu: Add hidapi.
* gnu/packages/libusb.scm (hidapi): New variable.
Diffstat (limited to 'gnu/packages/libusb.scm')
-rw-r--r--gnu/packages/libusb.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/libusb.scm b/gnu/packages/libusb.scm
index 0071f4f119..fe1bed1768 100644
--- a/gnu/packages/libusb.scm
+++ b/gnu/packages/libusb.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2015 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Theodoros Foradis <theodoros.for@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29,6 +30,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system python)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gtk)
#:use-module (gnu packages linux)
@@ -201,3 +203,39 @@ proposed for standardization.")
(MTP), which allows media files to be transferred to and from many portable
devices.")
(license bsd-3)))
+
+(define-public hidapi
+ (package
+ (name "hidapi")
+ (version "0.8.0-rc1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/signal11/hidapi/archive/hidapi-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0qdgyj9rgb7n0nk3ghfswrhzzknxqn4ibn3wj8g4r828pw07451w"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'bootstrap
+ (lambda _
+ (zero? (system* "autoreconf" "-vfi")))))))
+ (inputs
+ `(("libusb" ,libusb)
+ ("udev" ,eudev)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (home-page "http://www.signal11.us/oss/hidapi/")
+ (synopsis "HID API library")
+ (description
+ "HIDAPI is a library which allows an application to interface with USB and Bluetooth
+HID-Class devices.")
+ ;; HIDAPI can be used under one of three licenses.
+ (license (list gpl3
+ bsd-3
+ non-copyleft "file://LICENSE-orig.txt"))))