summaryrefslogtreecommitdiff
path: root/gnu/packages/libusb.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-08-05 15:51:44 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-01-18 20:27:58 +0100
commit0c90d4ad0a7e6d2288ec9d72e3711dbf9c5911a8 (patch)
tree3727c5cafc7ccecc548d61e3b65ccc3cb9b41a30 /gnu/packages/libusb.scm
parentdddf975ffb95368b9561fe8e9ab582366dddc8f7 (diff)
downloadguix-patches-0c90d4ad0a7e6d2288ec9d72e3711dbf9c5911a8.tar
guix-patches-0c90d4ad0a7e6d2288ec9d72e3711dbf9c5911a8.tar.gz
gnu: Add libimobiledevice.
* gnu/packages/libusb.scm (libimobiledevice): New variable.
Diffstat (limited to 'gnu/packages/libusb.scm')
-rw-r--r--gnu/packages/libusb.scm42
1 files changed, 41 insertions, 1 deletions
diff --git a/gnu/packages/libusb.scm b/gnu/packages/libusb.scm
index b5ace62923..e27cffa331 100644
--- a/gnu/packages/libusb.scm
+++ b/gnu/packages/libusb.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Andy Wingo <wingo@igalia.com>
-;;; Copyright © 2015, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2017 Jonathan Brielmaier <jonathan.brielmaier@web.de>
@@ -45,6 +45,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages tls)
#:use-module (gnu packages xiph))
(define-public libusb
@@ -346,6 +347,45 @@ connections from and to iOS devices by connecting to a socket provided by a
@code{usbmuxd} daemon.")
(license license:lgpl2.1+)))
+(define-public libimobiledevice
+ (package
+ (name "libimobiledevice")
+ (version "1.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.libimobiledevice.org/downloads/"
+ "libimobiledevice-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0dqhy4qwj30mw8pwckvjmgnj1qqrh6p8c6jknmhvylshhzh0ssvq"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list (string-append "PYTHON_LDFLAGS=-L"
+ (assoc-ref %build-inputs "python")
+ "/lib -lpython"
+ ,(version-major+minor (package-version python))
+ "m"))))
+ (propagated-inputs
+ `(("openssl" ,openssl)
+ ("libusbmuxd" ,libusbmuxd)))
+ (inputs
+ `(("libplist" ,libplist)
+ ("python" ,python)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("python-cython" ,python-cython)
+ ("libtool" ,libtool)))
+ (home-page "http://www.libimobiledevice.org/")
+ (synopsis "Protocol library and tools to communicate with Apple devices")
+ (description "libimobiledevice is a software library that talks the
+protocols to support Apple devices. It allows other software to easily access
+the device's filesystem, retrieve information about the device and it's
+internals, backup/restore the device, manage installed applications, retrieve
+addressbook/calendars/notes and bookmarks and (using libgpod) synchronize
+music and video to the device.")
+ (license license:lgpl2.1+)))
+
(define-public libmtp
(package
(name "libmtp")