summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-06 19:13:27 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-08 21:56:02 +0100
commitc6af97b70a46efc59e4bf22f4566ffa502306f3e (patch)
tree2a3f8ad24648ecd6f99aafa4cf6d2b172287bc3d /gnu/packages/libreoffice.scm
parent25a2f2efa16860dce461c469aae11a4d0993e816 (diff)
downloadguix-patches-c6af97b70a46efc59e4bf22f4566ffa502306f3e.tar
guix-patches-c6af97b70a46efc59e4bf22f4566ffa502306f3e.tar.gz
gnu: libfreehand: Fix build with ICU 65.
* gnu/packages/libreoffice.scm (libfreehand)[arguments]: New field.
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 038031b800..3283f1b402 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -482,6 +482,17 @@ library primarily intended for language guessing.")
(sha256 (base32
"1b1lvqh68rwij1yvmxy02hsmh7i74ma5767mk8mg5nx6chajshhf"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'build 'adjust-for-ICU-65
+ (lambda _
+ ;; Fix build with ICU 65 and later. Taken from this
+ ;; upstream commit, remove for libfreehand > 0.1.2:
+ ;; https://gerrit.libreoffice.org/#/c/80224/
+ (substitute* "src/lib/libfreehand_utils.cpp"
+ (("U16_NEXT.*" all)
+ (string-append all ";\n")))
+ #t)))))
(native-inputs
`(("cppunit" ,cppunit)
("doxygen" ,doxygen)