summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2018-09-11 07:58:36 +0200
committerLudovic Courtès <ludo@gnu.org>2018-09-11 17:46:30 +0200
commitaeba7d4650f6d725f4751aa142cd1aae5ee3be97 (patch)
tree0c6a6e45fdad61f62fcab402044ffbb37709348c /gnu/packages/libreoffice.scm
parentaa82260bc098c3a2142230c6b787c39c00843ce1 (diff)
downloadguix-patches-aeba7d4650f6d725f4751aa142cd1aae5ee3be97.tar
guix-patches-aeba7d4650f6d725f4751aa142cd1aae5ee3be97.tar.gz
gnu: Add libnumbertext.
* gnu/packages/libreoffice.scm (libnumbertext): New public variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 3dc7a4bbf2..d81f8aa793 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2018 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32,7 +33,7 @@
#:use-module (guix download)
#:use-module ((guix licenses)
#:select (gpl2+ lgpl2.1+ lgpl3+ mpl1.1 mpl2.0
- non-copyleft x11-style))
+ non-copyleft x11-style bsd-3))
#:use-module (guix packages)
#:use-module (guix utils)
#:use-module (ice-9 match)
@@ -524,6 +525,35 @@ Aldus/Macromedia/Adobe FreeHand documents.")
Microsoft Publisher documents of all versions.")
(license mpl2.0)))
+(define-public libnumbertext
+ (package
+ (name "libnumbertext")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/numbertext/" name
+ "/archive/" version ".tar.gz"))
+ (sha256
+ (base32
+ "0wnsn4911fdd2na8jxkcvmk04a6xw6qlviic9w4qwg9fcym6866v"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags '("--disable-static")))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/Numbertext/libnumbertext")
+ (synopsis "Language-neutral @code{NUMBERTEXT} and @code{MONEYTEXT} functions")
+ (description
+ "The libnumbertext library provides language-neutral @code{NUMBERTEXT}
+and @code{MONEYTEXT} functions for LibreOffice Calc, available for C++ and
+Java.")
+ (license (list lgpl3+ bsd-3))))
+
(define-public libpagemaker
(package
(name "libpagemaker")