summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-08 13:59:08 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-08 14:46:44 +0300
commit990704507be4ec0ef37f4d3e2f319421331fa59c (patch)
treede8fc992fd362c28b84746179510569ed8632922 /gnu/packages/libreoffice.scm
parent086183598e347812fa4d05e3661914a569fb0e29 (diff)
downloadguix-patches-990704507be4ec0ef37f4d3e2f319421331fa59c.tar
guix-patches-990704507be4ec0ef37f4d3e2f319421331fa59c.tar.gz
gnu: libe-book: Fix building with icu4c-69.
* gnu/packages/libreoffice.scm (libe-book)[source]: Add snippet to work around changes in icu4c's code.
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index c1e7a58c59..87a9494129 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -272,8 +272,16 @@ into other word processors.")
(uri (string-append "mirror://sourceforge/libebook/libe-book-"
version "/libe-book-" version ".tar.xz"))
(sha256
- (base32
- "1yg1vws1wggzhjw672bpgh2x541g5i9wryf67g51m0r79zrqz3by"))))
+ (base32
+ "1yg1vws1wggzhjw672bpgh2x541g5i9wryf67g51m0r79zrqz3by"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; This can be removed with the next release.
+ ;; Needed for icu4c compatibility >= 68.0.
+ (substitute* "src/lib/EBOOKCharsetConverter.cpp"
+ (("TRUE, TRUE, &status")
+ "true, true, &status"))))))
(build-system gnu-build-system)
(native-inputs
`(("cppunit" ,cppunit)