summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-16 18:46:42 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-16 23:32:43 +0100
commit8e9a84d957d7a6180e0866777e6d6f85a3b66058 (patch)
tree775d2284111a43c61b7cf77fb11a1321dc25744d /gnu/packages/libreoffice.scm
parent3d0574c4f3f03a866ca9196daf800c03dae31068 (diff)
downloadguix-patches-8e9a84d957d7a6180e0866777e6d6f85a3b66058.tar
guix-patches-8e9a84d957d7a6180e0866777e6d6f85a3b66058.tar.gz
gnu: libnumbertext: Update to 1.0.5.
* gnu/packages/libreoffice.scm (libnumbertext): Update to 1.0.5. [source]: Use a release tarball. [native-inputs]: Remove autoconf, automake, libtool, and pkg-config.
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm18
1 files changed, 6 insertions, 12 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index cb18ded5c6..dab819d9b2 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2016, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
-;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017, 2018, 2019 Marius Bakke <mbakke@fastmail.com>
@@ -527,24 +527,18 @@ Microsoft Publisher documents of all versions.")
(define-public libnumbertext
(package
(name "libnumbertext")
- (version "1.0")
+ (version "1.0.5")
(source
(origin
(method url-fetch)
- (uri (string-append "https://github.com/numbertext/" name
- "/archive/" version ".tar.gz"))
+ (uri (string-append "https://github.com/Numbertext/libnumbertext/"
+ "releases/download/" version
+ "/libnumbertext-" version ".tar.xz"))
(sha256
- (base32
- "0wnsn4911fdd2na8jxkcvmk04a6xw6qlviic9w4qwg9fcym6866v"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ (base32 "1xzlwhwwhvr76kfdsw5gvfjfdayz803z65h331gv5dpc9imhijg1"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--disable-static")))
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)))
(home-page "https://github.com/Numbertext/libnumbertext")
(synopsis "Language-neutral @code{NUMBERTEXT} and @code{MONEYTEXT} functions")
(description