summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-01-13 01:40:04 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-01-13 01:40:04 +0100
commit6764f94317be05d2c3b08acdcbb2c4730f0c617d (patch)
treeadcfd0000cbe9a8c614181e39d7cbe7f1e1bc164 /gnu/packages/libreoffice.scm
parent67ff2bdf6100cc887b0d5aebbcd1f539c634a3dc (diff)
parent1710ffa4c79c79079ebd4e523eef8883eb2d3953 (diff)
downloadguix-patches-6764f94317be05d2c3b08acdcbb2c4730f0c617d.tar
guix-patches-6764f94317be05d2c3b08acdcbb2c4730f0c617d.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm59
1 files changed, 18 insertions, 41 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index c88bf72c78..1a41c3e0ba 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2017, 2018 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2018, 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Jonathan Brielmaier <jonathan.brielmaier@web.de>
@@ -287,15 +287,15 @@ working with graphics in the WPG (WordPerfect Graphics) format.")
(define-public libcmis
(package
(name "libcmis")
- (version "0.5.1")
+ (version "0.5.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/tdf/libcmis/releases/download/v"
- version "/libcmis-" version ".tar.gz"))
+ version "/libcmis-" version ".tar.xz"))
(sha256
(base32
- "03kvl8ywsv5qrxblf0m6955mmvl5q2zpb6vj51vs7ayvxhidzjva"))))
+ "18h0a2gsfxvlv03nlcfvw9bzsflq5sin9agq6za103hr0ab8vcfp"))))
(build-system gnu-build-system)
(native-inputs
`(("cppunit" ,cppunit)
@@ -313,22 +313,10 @@ working with graphics in the WPG (WordPerfect Graphics) format.")
;; FIXME: Man pages generation requires docbook-to-man; reenable
;; it once this is available.
"--without-man"
- ;; avoid triggering configure errors by simple inclusion of
- ;; boost headers
- "--disable-werror"
;; During configure, the boost headers are found, but linking
;; fails without the following flag.
(string-append "--with-boost="
- (assoc-ref %build-inputs "boost")))
- #:phases (modify-phases %standard-phases
- (add-before 'build 'fix-boost-include
- (lambda _
- ;; This library moved in Boost and the compatibility
- ;; redirect is no longer available since version 1.68.0.
- (substitute* "src/libcmis/xml-utils.cxx"
- (("boost/uuid/sha1.hpp")
- "boost/uuid/detail/sha1.hpp"))
- #t)))))
+ (assoc-ref %build-inputs "boost")))))
(home-page "https://github.com/tdf/libcmis")
(synopsis "CMIS client library")
(description "LibCMIS is a C++ client library for the CMIS interface. It
@@ -370,14 +358,14 @@ AbiWord documents.")
(define-public libcdr
(package
(name "libcdr")
- (version "0.1.4")
+ (version "0.1.5")
(source
(origin
(method url-fetch)
- (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
+ (uri (string-append "https://dev-www.libreoffice.org/src/" name "/"
name "-" version ".tar.xz"))
(sha256 (base32
- "0vd6likgk51j46llybkx4wq3674xzrhp0k82220pkx9x1aqfi9z7"))))
+ "0j1skr11jwvafn0l6p37v3i4lqc8wcn489g8f7c4mqwbk94mrkka"))))
(build-system gnu-build-system)
(native-inputs
`(("cppunit" ,cppunit)
@@ -390,9 +378,6 @@ AbiWord documents.")
("zlib" ,zlib)))
(inputs
`(("boost" ,boost)))
- (arguments
- ;; avoid triggering a build failure due to warnings
- `(#:configure-flags '("--disable-werror")))
(home-page "https://wiki.documentfoundation.org/DLP/Libraries/libcdr")
(synopsis "Library for parsing the CorelDRAW format")
(description "Libcdr is a library that parses the file format of
@@ -402,39 +387,31 @@ CorelDRAW documents of all versions.")
(define-public libetonyek
(package
(name "libetonyek")
- (version "0.1.8")
+ (version "0.1.9")
(source
(origin
(method url-fetch)
(uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
name "-" version ".tar.xz"))
(sha256 (base32
- "0bfq9rwm040xhh7b3v0gsdavwvnrz4hkwnhpggarxk70mr3j7jcx"))))
+ "0jhsbdimiyijdqriy0zzkjjgc4wi6fjimhdg4mdybrlwg7l7f5p6"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--with-mdds=1.4")
- #:phases (modify-phases %standard-phases
- (add-before 'configure 'support-mdds-1.4
- (lambda _
- ;; This package already works fine with mdds 1.4, but the
- ;; configure check is too strict. Taken from upstream.
- (substitute* "configure"
- (("mdds=1\\.2") "mdds=1.4")
- (("mdds=\"1\\.2\"") "mdds=\"1.4\""))
- #t)))))
+ `(#:configure-flags '("--with-mdds=1.4")))
(native-inputs
`(("cppunit" ,cppunit)
("doxygen" ,doxygen)
- ("glm" ,glm)
("gperf" ,gperf)
- ("liblangtag" ,liblangtag)
- ("mdds" ,mdds)
("pkg-config" ,pkg-config)))
(propagated-inputs ; in Requires or Requires.private field of .pkg
- `(("librevenge" ,librevenge)
- ("libxml2" ,libxml2)))
+ `(("liblangtag" ,liblangtag)
+ ("librevenge" ,librevenge)
+ ("libxml2" ,libxml2)
+ ("zlib" ,zlib)))
(inputs
- `(("boost" ,boost)))
+ `(("boost" ,boost)
+ ("glm" ,glm)
+ ("mdds" ,mdds)))
(home-page "https://wiki.documentfoundation.org/DLP/Libraries/libetonyek")
(synopsis "Library for parsing the Apple Keynote format")
(description "Libetonyek is a library that parses the file format of