summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-01-30 14:54:28 -0500
committerLeo Famulari <leo@famulari.name>2020-02-13 20:13:10 -0500
commit1ce2467fd6d5f8da259be1c7609702814c716702 (patch)
treefafd1533181f891b94a25c85bf67a4b5fc5f2ba1 /gnu/packages/libreoffice.scm
parentb96aca92554f65096221f8d5bb4ba89c74f4c4b2 (diff)
downloadguix-patches-1ce2467fd6d5f8da259be1c7609702814c716702.tar
guix-patches-1ce2467fd6d5f8da259be1c7609702814c716702.tar.gz
gnu: LibreOffice: Update to 6.4.0.3.
* gnu/packages/libreoffice.scm (libreoffice): Update to 6.4.0.3. [inputs]: Add qrcodegen-cpp. [source]: Remove obsolete patches and substitutions. * gnu/packages/patches/libreoffice-glm.patch, gnu/packages/patches/libreoffice-icu.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm16
1 files changed, 4 insertions, 12 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 581f098524..539ada46e5 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -41,6 +41,7 @@
#:use-module (guix utils)
#:use-module (ice-9 match)
#:use-module (gnu packages)
+ #:use-module (gnu packages aidc)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
@@ -930,7 +931,7 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
(define-public libreoffice
(package
(name "libreoffice")
- (version "6.3.4.2")
+ (version "6.4.0.3")
(source
(origin
(method url-fetch)
@@ -940,17 +941,7 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
(version-prefix version 3) "/libreoffice-" version ".tar.xz"))
(sha256
(base32
- "1774vmf3lr5x24ikpn1z5vqcdwrhiwfkjy7sx09jqkvpm6d5awnb"))
- (patches (search-patches "libreoffice-icu.patch"
- "libreoffice-glm.patch"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (for-each (lambda (file)
- ;; Adjust to renamed function in Poppler 0.72.
- (substitute* file (("getCString") "c_str")))
- (find-files "sdext/source/pdfimport/xpdfwrapper"))
- #t))))
+ "09ra8a3ylb08xhy8wy233fs0f87klkpsbi9n3zss0c688afxjcf5"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("bison" ,bison)
@@ -1023,6 +1014,7 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
("postgresql" ,postgresql)
("python" ,python)
("python-lxml" ,python-lxml)
+ ("qrcodegen-cpp" ,qrcodegen-cpp)
("redland" ,redland)
("sane-backends" ,sane-backends)
("unixodbc" ,unixodbc)