summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-30 21:15:44 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-30 21:43:50 +0100
commit0d5578c12beec105f5ec113cc50deab703270a82 (patch)
tree0e2d7fb81426b9125f3479aa474651cca31f08fd /gnu/packages/libreoffice.scm
parentb9f8e36e5bc6fb4ea004bd2d6d725b22d62fe93a (diff)
downloadguix-patches-0d5578c12beec105f5ec113cc50deab703270a82.tar
guix-patches-0d5578c12beec105f5ec113cc50deab703270a82.tar.gz
gnu: libreoffice: Build reproducibly.
* gnu/packages/libreoffice.scm (libreoffice)[native-inputs]: Add ziptime. [arguments]: Add a 'reset-zip-timestamps phase that invokes it.
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index d2bf5b015b..714072e84b 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -1102,7 +1102,8 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
("flex" ,flex)
("pkg-config" ,pkg-config)
("python" ,python-wrapper)
- ("which" ,which)))
+ ("which" ,which)
+ ("ziptime" ,ziptime)))
(inputs
`(("bluez" ,bluez)
("boost" ,boost)
@@ -1216,6 +1217,13 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
"/bin/xdg-open")))
#t))
+ (add-after 'install 'reset-zip-timestamps
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (for-each (lambda (file)
+ (invoke "ziptime" file))
+ ;; So many different extensions for .zip files.
+ (find-files out "\\.(bau|dat|otp|ott|zip)$")))))
(add-after 'install 'bin-and-desktop-install
;; Create 'soffice' and 'libreoffice' symlinks to the executable
;; script.