summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-01-03 00:38:28 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-01-13 01:25:15 +0100
commit0c4cee13b26a953e54f47da081e1f461b46c1976 (patch)
tree8bb116a432fe7260d7e4cd57a17f20f4814165e7 /gnu/packages/libreoffice.scm
parent48a51af9d2c14e46ee073c6925e0d1b68e3292c9 (diff)
downloadguix-patches-0c4cee13b26a953e54f47da081e1f461b46c1976.tar
guix-patches-0c4cee13b26a953e54f47da081e1f461b46c1976.tar.gz
gnu: libcmis: Update to 0.5.2.
* gnu/packages/libreoffice.scm (libcmis): Update to 0.5.2. [source](uri): Use XZ-compressed tarball. [arguments]: Remove #:phases. Don't pass "--disable-werror" in #:configure-flags.
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm20
1 files changed, 4 insertions, 16 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 2cbb0ca2e5..ccef2c2e9b 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -287,15 +287,15 @@ working with graphics in the WPG (WordPerfect Graphics) format.")
(define-public libcmis
(package
(name "libcmis")
- (version "0.5.1")
+ (version "0.5.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/tdf/libcmis/releases/download/v"
- version "/libcmis-" version ".tar.gz"))
+ version "/libcmis-" version ".tar.xz"))
(sha256
(base32
- "03kvl8ywsv5qrxblf0m6955mmvl5q2zpb6vj51vs7ayvxhidzjva"))))
+ "18h0a2gsfxvlv03nlcfvw9bzsflq5sin9agq6za103hr0ab8vcfp"))))
(build-system gnu-build-system)
(native-inputs
`(("cppunit" ,cppunit)
@@ -313,22 +313,10 @@ working with graphics in the WPG (WordPerfect Graphics) format.")
;; FIXME: Man pages generation requires docbook-to-man; reenable
;; it once this is available.
"--without-man"
- ;; avoid triggering configure errors by simple inclusion of
- ;; boost headers
- "--disable-werror"
;; During configure, the boost headers are found, but linking
;; fails without the following flag.
(string-append "--with-boost="
- (assoc-ref %build-inputs "boost")))
- #:phases (modify-phases %standard-phases
- (add-before 'build 'fix-boost-include
- (lambda _
- ;; This library moved in Boost and the compatibility
- ;; redirect is no longer available since version 1.68.0.
- (substitute* "src/libcmis/xml-utils.cxx"
- (("boost/uuid/sha1.hpp")
- "boost/uuid/detail/sha1.hpp"))
- #t)))))
+ (assoc-ref %build-inputs "boost")))))
(home-page "https://github.com/tdf/libcmis")
(synopsis "CMIS client library")
(description "LibCMIS is a C++ client library for the CMIS interface. It