summaryrefslogtreecommitdiff
path: root/gnu/packages/libffi.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-28 10:23:37 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-28 10:23:37 +0300
commit8df29c26ba184874561c67e48f69fd3526156516 (patch)
treeedc72f1bccc9265a25f41ccf3fa6cb115b5e8702 /gnu/packages/libffi.scm
parent9ad4d90a6104b5d433b156f270af5f902f880ca9 (diff)
downloadguix-patches-8df29c26ba184874561c67e48f69fd3526156516.tar
guix-patches-8df29c26ba184874561c67e48f69fd3526156516.tar.gz
gnu: ruby-ffi: Update to 1.15.5.
* gnu/packages/libffi.scm (ruby-ffi): Update to 1.15.5. [arguments]: Remove custom 'do-not-depend-on-ccache phase. Adjust custom 'remove-git-ls-files phase to changes in the code. Remove trailing #t from phases.
Diffstat (limited to 'gnu/packages/libffi.scm')
-rw-r--r--gnu/packages/libffi.scm20
1 files changed, 7 insertions, 13 deletions
diff --git a/gnu/packages/libffi.scm b/gnu/packages/libffi.scm
index 701feeb773..99a07ceaac 100644
--- a/gnu/packages/libffi.scm
+++ b/gnu/packages/libffi.scm
@@ -184,28 +184,22 @@ project.")
(define-public ruby-ffi
(package
(name "ruby-ffi")
- (version "1.12.2")
+ (version "1.15.5")
(source (origin
;; Pull from git because the RubyGems release bundles LibFFI,
;; and comes with a gemspec that makes it difficult to unbundle.
(method git-fetch)
(uri (git-reference
(url "https://github.com/ffi/ffi")
- (commit version)))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "1cvqsbjr2gfjgqggq9kdx90qhhzr7qkyr9wmxdsfsik6cnxnnpmd"))))
+ "1qk55s1zwpdjykwkj9l37m71i5n228i7f8bg3ply3ks9py16m7s6"))))
(build-system ruby-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'do-not-depend-on-ccache
- (lambda _
- (substitute* "spec/ffi/fixtures/GNUmakefile"
- (("^CCACHE := .*")
- ""))
- #t))
(replace 'replace-git-ls-files
(lambda _
;; Do not try to execute git, or include the (un)bundled LibFFI.
@@ -215,9 +209,10 @@ project.")
(("lfs \\+?= .*")
"lfs = []\n"))
(substitute* "Rakefile"
+ (("git .*ls-files -z")
+ "find * -type f -print0 | sort -z")
(("LIBFFI_GIT_FILES = .*")
- "LIBFFI_GIT_FILES = []\n"))
- #t))
+ "LIBFFI_GIT_FILES = []\n"))))
(replace 'build
(lambda _
;; Tests depend on the native extensions, so we build it
@@ -236,8 +231,7 @@ project.")
(setenv "MAKE" "make")
(setenv "CC" "gcc")
(invoke "rspec" "spec"))
- (format #t "test suite not run~%"))
- #t)))))
+ (format #t "test suite not run~%")))))))
(native-inputs
(list ruby-rake-compiler ruby-rspec ruby-rubygems-tasks))
(inputs