summaryrefslogtreecommitdiff
path: root/gnu/packages/libffi.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-20 04:24:19 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-20 16:06:10 +0100
commit667e6f1e24b12ba7f37ad518c40cf66c98ce8625 (patch)
tree3156e1818a0be197b97a4e4e23c4cdcad1b54f32 /gnu/packages/libffi.scm
parentd2d1144d61e83131ec3f9eca0c68d060dfeb9454 (diff)
downloadguix-patches-667e6f1e24b12ba7f37ad518c40cf66c98ce8625.tar
guix-patches-667e6f1e24b12ba7f37ad518c40cf66c98ce8625.tar.gz
gnu: libffi: Update phase style.
* gnu/packages/libffi.scm (libffi): Move let-bound POST-INSTALL-PHASE to... [arguments]: ...here, use MODIFY-PHASES syntax, and end phase with #t.
Diffstat (limited to 'gnu/packages/libffi.scm')
-rw-r--r--gnu/packages/libffi.scm40
1 files changed, 20 insertions, 20 deletions
diff --git a/gnu/packages/libffi.scm b/gnu/packages/libffi.scm
index 948dabb41e..d55e7aec3d 100644
--- a/gnu/packages/libffi.scm
+++ b/gnu/packages/libffi.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -35,29 +36,28 @@
#:use-module (guix build-system ruby))
(define-public libffi
- (let ((post-install-phase
- ;; Keep headers where libffi.pc expects them, but also make them
- ;; available in $includedir where some users expect them.
- '(lambda* (#:key outputs #:allow-other-keys)
- (define out (assoc-ref outputs "out"))
- (symlink (string-append out "/lib/libffi-3.2.1/include")
- (string-append out "/include")))))
- (package
+ (package
(name "libffi")
(version "3.2.1")
(source (origin
- (method url-fetch)
- (uri
- (string-append "ftp://sourceware.org/pub/libffi/"
- name "-" version ".tar.gz"))
- (sha256
- (base32
- "0dya49bnhianl0r65m65xndz6ls2jn1xngyn72gd28ls3n7bnvnh"))
- (patches (search-patches "libffi-3.2.1-complex-alpha.patch"))))
+ (method url-fetch)
+ (uri
+ (string-append "ftp://sourceware.org/pub/libffi/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0dya49bnhianl0r65m65xndz6ls2jn1xngyn72gd28ls3n7bnvnh"))
+ (patches (search-patches "libffi-3.2.1-complex-alpha.patch"))))
(build-system gnu-build-system)
- (arguments `(#:phases (alist-cons-after 'install 'post-install
- ,post-install-phase
- %standard-phases)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'post-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (define out (assoc-ref outputs "out"))
+ (symlink (string-append out "/lib/libffi-3.2.1/include")
+ (string-append out "/include"))
+ #t)))))
(outputs '("out" "debug"))
(synopsis "Foreign function call interface library")
(description
@@ -74,7 +74,7 @@ conversions for values passed between the two languages.")
(home-page "http://sources.redhat.com/libffi/")
;; See <https://github.com/atgreen/libffi/blob/master/LICENSE>.
- (license expat))))
+ (license expat)))
(define-public python-cffi
(package