summaryrefslogtreecommitdiff
path: root/gnu/packages/libffi.scm
diff options
context:
space:
mode:
authorChris Marusich <cmmarusich@gmail.com>2020-12-27 19:57:15 -0800
committerChris Marusich <cmmarusich@gmail.com>2020-12-27 20:03:57 -0800
commit662e7e28d576ada91fc9dec7d27c100666114f03 (patch)
treef6e4a0f5e2a7e5b5060057f3c76ce9e083388666 /gnu/packages/libffi.scm
parentfdb90e9ee8a578c88ef3a33067e8a532e43ae7b8 (diff)
downloadguix-patches-662e7e28d576ada91fc9dec7d27c100666114f03.tar
guix-patches-662e7e28d576ada91fc9dec7d27c100666114f03.tar.gz
gnu: libffi: On powerpc, patch with --force.
As explained in bug 45252, this is the right way to invoke it. Efraim has confirmed that it is OK to make this change on master branch for the generic powerpc case, even though it will in theory cause rebuilds on that architecture, since in practice it isn't actually being used yet. * gnu/packages/libffi.scm (arguments): Change the invocation of the "patch" tool in the case where the %current-target-system or %current-system begins with "powerpc", so that we invoke it using --force instead of --batch.
Diffstat (limited to 'gnu/packages/libffi.scm')
-rw-r--r--gnu/packages/libffi.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/libffi.scm b/gnu/packages/libffi.scm
index 375a792ebf..5b8f277009 100644
--- a/gnu/packages/libffi.scm
+++ b/gnu/packages/libffi.scm
@@ -66,7 +66,7 @@
(lambda* (#:key inputs #:allow-other-keys)
(let ((patch (assoc-ref inputs
"powerpc-patch")))
- (invoke "patch" "--batch" "-p1"
+ (invoke "patch" "--force" "-p1"
"-i" patch))))))
'())
,@(if (string-prefix? "powerpc64le-" (or (%current-target-system)