summaryrefslogtreecommitdiff
path: root/gnu/packages/libffi.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-17 08:03:29 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-24 20:44:35 +0100
commit41fdad9f8c48a674d758c9835ab8640a9192a1a6 (patch)
tree87b8ff2e2218e47bfb9525b917865b8f3b935e1b /gnu/packages/libffi.scm
parent96af5dcf917853e40c6b17a2969fb44c161e096c (diff)
downloadguix-patches-41fdad9f8c48a674d758c9835ab8640a9192a1a6.tar
guix-patches-41fdad9f8c48a674d758c9835ab8640a9192a1a6.tar.gz
gnu: python-cffi: Update to 1.13.2.
* gnu/packages/patches/python-cffi-x87-stack-clean.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/libffi.scm (python-cffi): Update to 1.13.2. [arguments]: Adjust substitution. Remove obsolete phase.
Diffstat (limited to 'gnu/packages/libffi.scm')
-rw-r--r--gnu/packages/libffi.scm16
1 files changed, 4 insertions, 12 deletions
diff --git a/gnu/packages/libffi.scm b/gnu/packages/libffi.scm
index 52654ddf3f..b0098389c0 100644
--- a/gnu/packages/libffi.scm
+++ b/gnu/packages/libffi.scm
@@ -76,14 +76,13 @@ conversions for values passed between the two languages.")
(define-public python-cffi
(package
(name "python-cffi")
- (version "1.11.5")
+ (version "1.13.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "cffi" version))
(sha256
- (base32 "1x3lrj928dcxx1k8k9gf3s4s3jwvzv8mc3kkyg1g7c3a1sc1f3z9"))
- (patches (search-patches "python-cffi-x87-stack-clean.patch"))))
+ (base32 "0iikq5rn9a405n94c7s2j6kq3jv5qs9q4xyik8657b2py27ix6jr"))))
(build-system python-build-system)
(inputs
`(("libffi" ,libffi)))
@@ -116,7 +115,7 @@ conversions for values passed between the two languages.")
"compiler_so='gcc',linker_exe='gcc',"
"linker_so='gcc -shared')")))
(substitute* "testing/cffi0/test_ownlib.py"
- (("'cc testownlib") "'gcc testownlib"))
+ (("\"cc testownlib") "\"gcc testownlib"))
(invoke "py.test" "-v" "c/" "testing/")
#t))
(add-before 'check 'patch-paths-of-dynamically-loaded-libraries
@@ -142,14 +141,7 @@ conversions for values passed between the two languages.")
(substitute* "c/test_c.py"
(("find_and_load_library\\(['\"]{1}c['\"]{1}")
(format #f "find_and_load_library('~a'" libc)))
- #t)))
- (add-before 'check 'disable-failing-test
- ;; This is assumed to be a libffi issue:
- ;; https://bitbucket.org/cffi/cffi/issues/312/tests-failed-with-armv8
- (lambda _
- (substitute* "testing/cffi0/test_ownlib.py"
- (("ret.left") "ownlib.left"))
- #t)))))
+ #t))))))
(home-page "https://cffi.readthedocs.io/")
(synopsis "Foreign function interface for Python")
(description "Foreign Function Interface for Python calling C code.")