summaryrefslogtreecommitdiff
path: root/gnu/packages/libffi.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-22 16:52:32 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-01 11:53:47 -0500
commit220a153c2fa70e4b02ae0e96502fd18a14bf1834 (patch)
tree04f06d89e9d01021094b1604d62b0eef36005c02 /gnu/packages/libffi.scm
parentfcaec1c756c03743ea67206d4eedf58165c28088 (diff)
downloadguix-patches-220a153c2fa70e4b02ae0e96502fd18a14bf1834.tar
guix-patches-220a153c2fa70e4b02ae0e96502fd18a14bf1834.tar.gz
gnu: python-cffi: Do not set PYTHONPATH.
* gnu/packages/libffi.scm (python-cffi): Remove trailing #t. [phases]{check}: Do not set PYTHONPATH.
Diffstat (limited to 'gnu/packages/libffi.scm')
-rw-r--r--gnu/packages/libffi.scm20
1 files changed, 4 insertions, 16 deletions
diff --git a/gnu/packages/libffi.scm b/gnu/packages/libffi.scm
index 998df6ce61..0f549bdbda 100644
--- a/gnu/packages/libffi.scm
+++ b/gnu/packages/libffi.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2016, 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2017, 2019, 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2019, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 John Doe <dftxbs3e@free.fr>
;;;
;;; This file is part of GNU Guix.
@@ -128,20 +128,10 @@ conversions for values passed between the two languages.")
`(("pkg-config" ,pkg-config)
("python-pytest" ,python-pytest)))
(arguments
- `(#:modules ((ice-9 ftw)
- (srfi srfi-26)
- (guix build utils)
- (guix build python-build-system))
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(replace 'check
(lambda _
- (setenv "PYTHONPATH"
- (string-append
- (getenv "PYTHONPATH")
- ":" (getcwd) "/build/"
- (car (scandir "build" (cut string-prefix? "lib." <>)))))
-
;; XXX The "normal" approach of setting CC and friends does
;; not work here. Is this the correct way of doing things?
(substitute* "testing/embedding/test_basic.py"
@@ -152,8 +142,7 @@ conversions for values passed between the two languages.")
"linker_so='gcc -shared')")))
(substitute* "testing/cffi0/test_ownlib.py"
(("\"cc testownlib") "\"gcc testownlib"))
- (invoke "py.test" "-v" "c/" "testing/")
- #t))
+ (invoke "py.test" "-v" "c/" "testing/")))
(add-before 'check 'patch-paths-of-dynamically-loaded-libraries
(lambda* (#:key inputs #:allow-other-keys)
;; Shared libraries should be referred by their absolute path as
@@ -176,8 +165,7 @@ conversions for values passed between the two languages.")
(format #f "lib_m = ['~a']" libm)))
(substitute* "c/test_c.py"
(("find_and_load_library\\(['\"]{1}c['\"]{1}")
- (format #f "find_and_load_library('~a'" libc)))
- #t))))))
+ (format #f "find_and_load_library('~a'" libc)))))))))
(home-page "https://cffi.readthedocs.io/")
(synopsis "Foreign function interface for Python")
(description "Foreign Function Interface for Python calling C code.")