summaryrefslogtreecommitdiff
path: root/gnu/packages/libffi.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2013-11-03 18:20:00 -0500
committerMark H Weaver <mhw@netris.org>2013-11-03 23:26:04 -0500
commit1602fcea18879f855f906cf21bb6ee849cbf62c2 (patch)
tree01ed85a25c073a9cec302e6125467d40692d241b /gnu/packages/libffi.scm
parentbf2cc1e5d14df7d8ff0c9456798d48fba65de317 (diff)
downloadguix-patches-1602fcea18879f855f906cf21bb6ee849cbf62c2.tar
guix-patches-1602fcea18879f855f906cf21bb6ee849cbf62c2.tar.gz
gnu: libffi: fix handling of uint32_t arguments on MIPS N32.
* gnu/packages/patches/libffi-mips-n32-fix.patch: New file. * gnu/packages/libffi.scm (libffi): Add patch. * gnu-system.am (dist_patch_DATA): Add patch.
Diffstat (limited to 'gnu/packages/libffi.scm')
-rw-r--r--gnu/packages/libffi.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/libffi.scm b/gnu/packages/libffi.scm
index e4a2761273..d1a834d9c5 100644
--- a/gnu/packages/libffi.scm
+++ b/gnu/packages/libffi.scm
@@ -17,6 +17,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages libffi)
+ #:use-module (gnu packages)
#:use-module (guix licenses)
#:use-module (guix packages)
#:use-module (guix download)
@@ -46,7 +47,8 @@
name "-" version ".tar.gz"))
(sha256
(base32
- "077ibkf84bvcd6rw1m6jb107br63i2pp301rkmsbgg6300adxp8x"))))
+ "077ibkf84bvcd6rw1m6jb107br63i2pp301rkmsbgg6300adxp8x"))
+ (patches (list (search-patch "libffi-mips-n32-fix.patch")))))
(build-system gnu-build-system)
(arguments `(#:modules ((guix build utils) (guix build gnu-build-system)
(ice-9 ftw) (srfi srfi-26))