summaryrefslogtreecommitdiff
path: root/gnu/packages/libffi.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-12-21 23:44:54 +0100
committerMarius Bakke <marius@gnu.org>2020-12-21 23:44:54 +0100
commit119fd58922b00d43d4f8b055f3f622478a13f46d (patch)
tree4869f9f09079d5a33f7dfd51ca8e52200fbeb09f /gnu/packages/libffi.scm
parent85ba5e9335207beef9a650e96d5d64787beb9256 (diff)
parentbbe4ed65ed5fe7dc8ed9d226042852387cee3b1e (diff)
downloadguix-patches-119fd58922b00d43d4f8b055f3f622478a13f46d.tar
guix-patches-119fd58922b00d43d4f8b055f3f622478a13f46d.tar.gz
Merge branch 'ungrafting' into staging
Diffstat (limited to 'gnu/packages/libffi.scm')
-rw-r--r--gnu/packages/libffi.scm26
1 files changed, 21 insertions, 5 deletions
diff --git a/gnu/packages/libffi.scm b/gnu/packages/libffi.scm
index a9b3e051d7..55c908b0c6 100644
--- a/gnu/packages/libffi.scm
+++ b/gnu/packages/libffi.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2017, 2019, 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020 John Doe <dftxbs3e@free.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -57,7 +58,7 @@
;; compiler. See "ax_cc_maxopt.m4" and "ax_gcc_archflag.m4".
#:configure-flags '("--enable-portable-binary" "--without-gcc-arch")
- ;; TODO: Inline patch on next rebuild cycle.
+ ;; TODO: Inline patches on next rebuild cycle.
,@(if (string-prefix? "powerpc-" (or (%current-target-system)
(%current-system)))
'(#:phases (modify-phases %standard-phases
@@ -67,13 +68,28 @@
"powerpc-patch")))
(invoke "patch" "--batch" "-p1"
"-i" patch))))))
+ '())
+ ,@(if (string-prefix? "powerpc64le-" (or (%current-target-system)
+ (%current-system)))
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'apply-patch2
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((patch (assoc-ref inputs
+ "powerpc64le-patch")))
+ (invoke "patch" "--batch" "-p1"
+ "-i" patch))))))
'())))
(inputs
- (if (string-prefix? "powerpc-" (or (%current-target-system)
+ (cond
+ ((string-prefix? "powerpc-" (or (%current-target-system)
(%current-system)))
- `(("powerpc-patch" ,@(search-patches
- "libffi-3.3-powerpc-fixes.patch")))
- '()))
+ `(("powerpc-patch" ,@(search-patches
+ "libffi-3.3-powerpc-fixes.patch"))))
+ ((string-prefix? "powerpc64le-" (or (%current-target-system)
+ (%current-system)))
+ `(("powerpc64le-patch" ,@(search-patches
+ "libffi-float128-powerpc64le.patch"))))
+ (else '())))
(outputs '("out" "debug"))
(synopsis "Foreign function call interface library")
(description