summaryrefslogtreecommitdiff
path: root/gnu/packages/libffcall.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-06-24 23:48:04 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-06-24 23:48:20 +0300
commit6e13e2bd01bb69b62abd8fa6b1de885132850c26 (patch)
tree18df0b6ceb0acbf2397c9cd307b86bcd7a72b5d3 /gnu/packages/libffcall.scm
parent730c0790fc5b3285cd0f1983804e2d76c37cb542 (diff)
downloadguix-patches-6e13e2bd01bb69b62abd8fa6b1de885132850c26.tar
guix-patches-6e13e2bd01bb69b62abd8fa6b1de885132850c26.tar.gz
gnu: libffcall: Update to 1.13.
* gnu/packages/libffcall.scm (libffcall): Update to 1.13. [source]: Use url-fetch, download from GNU mirror. [supported-systems]: Remove field.
Diffstat (limited to 'gnu/packages/libffcall.scm')
-rw-r--r--gnu/packages/libffcall.scm16
1 files changed, 5 insertions, 11 deletions
diff --git a/gnu/packages/libffcall.scm b/gnu/packages/libffcall.scm
index e4babfed2c..a8b4135caf 100644
--- a/gnu/packages/libffcall.scm
+++ b/gnu/packages/libffcall.scm
@@ -20,27 +20,22 @@
(define-module (gnu packages libffcall)
#:use-module ((guix licenses) #:prefix l:)
- #:use-module (guix utils) ; string-replace-substring
#:use-module (guix packages)
#:use-module (guix download)
- #:use-module (guix git-download)
#:use-module (guix build-system gnu))
(define-public libffcall
(package
(name "libffcall")
- (version "1.12")
+ (version "1.13")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.savannah.gnu.org/r/libffcall.git")
- (commit (string-append
- "ffcall-" (string-replace-substring version "." "-")))))
- (file-name (string-append name "-" version "-checkout"))
+ (method url-fetch)
+ (uri (string-append
+ "mirror://gnu/libffcall/libffcall-" version ".tar.gz"))
(sha256
(base32
- "0p7gg5k4ifcqpmrmdfmr2r4x909cn35g87iff539p6i8891fdfxf"))))
+ "1rxwkfr0p7vdv6q6x8nmn13611nsq0lnk9cspqdpzxdvgmqcw1qp"))))
(build-system gnu-build-system)
(arguments `(#:parallel-build? #f))
(synopsis "Foreign function calls from interpreters")
@@ -48,5 +43,4 @@
"GNU Libffcall is a collection of libraries that can be used to build
foreign function call interfaces in embedded interpreters.")
(home-page "https://www.gnu.org/software/libffcall/")
- (supported-systems (delete "aarch64-linux" %supported-systems))
(license l:gpl2+)))