summaryrefslogtreecommitdiff
path: root/gnu/packages/libevent.scm
diff options
context:
space:
mode:
authorEric Dvorsak <eric@dvorsak.fr>2015-08-17 22:06:02 +0200
committerEric Bavier <bavier@member.fsf.org>2015-08-23 11:26:10 -0500
commitc808ca02ddc0eaac2c6b07e7814cdbb27437d64c (patch)
treeaf0dc864eaf585b401bfb31a16445e1363fc3f15 /gnu/packages/libevent.scm
parentd8f1c07499d31dbb2e809a43e2448df0158ad875 (diff)
downloadguix-patches-c808ca02ddc0eaac2c6b07e7814cdbb27437d64c.tar
guix-patches-c808ca02ddc0eaac2c6b07e7814cdbb27437d64c.tar.gz
gnu: Add libev.
* gnu/packages/libevent.scm (libev): New variable. Signed-off-by: Eric Bavier <bavier@member.fsf.org>
Diffstat (limited to 'gnu/packages/libevent.scm')
-rw-r--r--gnu/packages/libevent.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index 88b13ecbc9..a193959e60 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -61,6 +62,30 @@ then add or remove events dynamically without having to change the event
loop.")
(license bsd-3)))
+(define-public libev
+ (package
+ (name "libev")
+ (version "4.20")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://dist.schmorp.de/libev/libev-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "17j47pbkr65a18mfvy2861p5k7w4pxmdgiw723ryfqd9gx636w7q"))))
+ (build-system gnu-build-system)
+ (home-page "http://software.schmorp.de/pkg/libev.html")
+ (synopsis "Event loop loosely modelled after libevent")
+ (description
+ "libev is a full-featured and high-performance event loop that
+is loosely modelled after libevent, but without its limitations and
+bugs. It is used in GNU Virtual Private Ethernet, rxvt-unicode,
+auditd, the Deliantra MORPG Server and Client, and many other
+programs.")
+ (license
+ (list bsd-2 gpl2+))))
+
(define-public libuv
(package
(name "libuv")