summaryrefslogtreecommitdiff
path: root/gnu/packages/libevent.scm
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2021-03-30 01:27:32 -0400
committerJelle Licht <jlicht@fsfe.org>2021-04-02 18:04:22 +0200
commitc39092c7b8cb6ba39efedae78a8356e2e4ad76ee (patch)
treefe204d2c22b19e12029ef992b8ed9e088bfbda8a /gnu/packages/libevent.scm
parent23ea84cdf07c9b6bd4a61d14e5cb6009060f87cf (diff)
downloadguix-patches-c39092c7b8cb6ba39efedae78a8356e2e4ad76ee.tar
guix-patches-c39092c7b8cb6ba39efedae78a8356e2e4ad76ee.tar.gz
gnu: Add libuv-for-node
* gnu/packages/libevent.scm (libuv-for-node): New variable.
Diffstat (limited to 'gnu/packages/libevent.scm')
-rw-r--r--gnu/packages/libevent.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index 7109d9a88d..0e683570d3 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -134,6 +134,22 @@ resolution, asynchronous file system operations, and threading primitives.")
;; details. Documentation is CC-BY 4.0 as of 1.12.0; see 'LICENSE-docs'.
(license (list expat cc-by4.0))))
+(define-public libuv-for-node
+ ;; When upgrading Node, also upgrade this. Get the version from
+ ;; https://github.com/nodejs/node/blob/master/deps/uv/include/uv/version.h
+ (package
+ (inherit libuv)
+ (name "libuv")
+ (version "1.40.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://dist.libuv.org/dist/v" version
+ "/libuv-v" version ".tar.gz"))
+ (sha256
+ (base32
+ "1551k3ab27vbg9517l9b4iqbramwxdkwgpf53knas05cbfwhvab1"))))
+ (properties '((hidden? . #t)))))
+
(define-public perl-anyevent
(package
(name "perl-anyevent")