summaryrefslogtreecommitdiff
path: root/gnu/packages/libevent.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/libevent.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/libevent.scm')
-rw-r--r--gnu/packages/libevent.scm35
1 files changed, 15 insertions, 20 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index 0b4a244076..b3a5cd915e 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -60,7 +60,7 @@
(inputs
`(("python" ,python-wrapper))) ;for 'event_rpcgen.py'
(native-inputs
- `(("which" ,which)))
+ (list which))
(home-page "https://libevent.org/")
(synopsis "Event notification library")
(description
@@ -117,12 +117,9 @@ limited support for fork events.")
'(#:configure-flags '("--disable-static")
;; XXX: Some tests want /dev/tty, attempt to make connections, etc.
#:tests? #f))
- (native-inputs `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
-
- ;; libuv.pc is installed only when pkg-config is found.
- ("pkg-config" ,pkg-config)))
+ (native-inputs (list autoconf automake libtool
+ ;; libuv.pc is installed only when pkg-config is found.
+ pkg-config))
(home-page "https://github.com/libuv/libuv")
(synopsis "Library for asynchronous I/O")
(description
@@ -185,15 +182,15 @@ resolution, asynchronous file system operations, and threading primitives.")
"11drlj8r02czhjgzkb39axnr8zzyp506r043xfmf93q9kilfmgjh"))))
(build-system perl-build-system)
(native-inputs
- `(("perl-canary-stability" ,perl-canary-stability)))
+ (list perl-canary-stability))
(propagated-inputs
- `(("perl-async-interrupt" ,perl-async-interrupt)
- ("perl-ev" ,perl-ev)
- ("perl-guard" ,perl-guard)
- ("perl-json" ,perl-json)
- ("perl-json-xs" ,perl-json-xs)
- ("perl-net-ssleay" ,perl-net-ssleay)
- ("perl-task-weaken" ,perl-task-weaken)))
+ (list perl-async-interrupt
+ perl-ev
+ perl-guard
+ perl-json
+ perl-json-xs
+ perl-net-ssleay
+ perl-task-weaken))
(home-page "https://metacpan.org/release/AnyEvent")
(synopsis
"API for I/O, timer, signal, child process and completion events")
@@ -238,7 +235,7 @@ not rely on XS.")
`(("libev-source" ,(package-source libev))
("perl-canary-stability" ,perl-canary-stability)))
(propagated-inputs
- `(("perl-common-sense" ,perl-common-sense)))
+ (list perl-common-sense))
(home-page "https://metacpan.org/release/EV")
(synopsis "Perl interface to libev")
(description
@@ -262,11 +259,9 @@ and still be faster than other event loops currently supported in Perl.")
"1qwb284z4ig3xzy21m1b3w8bkb8k6l2ij6cjz93znn2j6qs42pwp"))))
(build-system perl-build-system)
(native-inputs
- `(("perl-module-build" ,perl-module-build)
- ("perl-test-simple" ,perl-test-simple)))
+ (list perl-module-build perl-test-simple))
(propagated-inputs
- `(("perl-anyevent" ,perl-anyevent)
- ("perl-data-sexpression" ,perl-data-sexpression)))
+ (list perl-anyevent perl-data-sexpression))
(arguments
;; Tests seem to fail because they try to start a server.
`(#:tests? #f))