summaryrefslogtreecommitdiff
path: root/gnu/packages/libevent.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-25 16:44:07 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-25 16:44:07 +0200
commit839167ff9d74fc490b32f6a197591964f73b65e5 (patch)
treed193bfad7c9ef5597c5cd7d2ea25fd007d01f88a /gnu/packages/libevent.scm
parent27c1df05a866b639a61e16d48b3f2da8fa5eb767 (diff)
parent030c912616c8ee1595218e304460041bcb4f1ceb (diff)
downloadguix-patches-839167ff9d74fc490b32f6a197591964f73b65e5.tar
guix-patches-839167ff9d74fc490b32f6a197591964f73b65e5.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/libevent.scm')
-rw-r--r--gnu/packages/libevent.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index 21c8d2a079..bc7f6c670d 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -173,7 +174,7 @@ resolution, asynchronous file system operations, and threading primitives.")
("perl-json-xs" ,perl-json-xs)
("perl-net-ssleay" ,perl-net-ssleay)
("perl-task-weaken" ,perl-task-weaken)))
- (home-page "http://search.cpan.org/dist/AnyEvent")
+ (home-page "https://metacpan.org/release/AnyEvent")
(synopsis
"API for I/O, timer, signal, child process and completion events")
(description
@@ -211,14 +212,14 @@ not rely on XS.")
;; to build. Unpack system libev here...
(lambda* (#:key inputs #:allow-other-keys)
(mkdir "./libev")
- (zero? (system* "tar" "-xf" (assoc-ref inputs "libev-source")
- "-C" "./libev" "--strip-components=1")))))))
+ (invoke "tar" "-xf" (assoc-ref inputs "libev-source")
+ "-C" "./libev" "--strip-components=1"))))))
(native-inputs
`(("libev-source" ,(package-source libev))
("perl-canary-stability" ,perl-canary-stability)))
(propagated-inputs
`(("perl-common-sense" ,perl-common-sense)))
- (home-page "http://search.cpan.org/dist/EV")
+ (home-page "https://metacpan.org/release/EV")
(synopsis "Perl interface to libev")
(description
"This module provides an interface to @code{libev}, a high performance