summaryrefslogtreecommitdiff
path: root/gnu/packages/libevent.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-26 14:18:26 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-26 19:48:39 +0200
commit0d3dbe3f56949ad07d8a3816a8a884d3726d2c7d (patch)
tree37296a96da375e1a58bf7f38cc4c170e3a68efaf /gnu/packages/libevent.scm
parent304fb7000ab2ccafa5861f8be15212dc1ef850ef (diff)
downloadguix-patches-0d3dbe3f56949ad07d8a3816a8a884d3726d2c7d.tar
guix-patches-0d3dbe3f56949ad07d8a3816a8a884d3726d2c7d.tar.gz
gnu: libevent: Update to 2.1.0.
* gnu/packages/patches/libevent-2.1-dns-tests.patch, gnu/packages/patches/libevent-2.1-skip-failing-test.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/libevent.scm (libevent): Update to 2.1.10. [source](patches): Remove.
Diffstat (limited to 'gnu/packages/libevent.scm')
-rw-r--r--gnu/packages/libevent.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index 01e1e3b00a..72227c1d95 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015, 2017 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
-;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
@@ -41,7 +41,7 @@
(define-public libevent
(package
(name "libevent")
- (version "2.1.8")
+ (version "2.1.10")
(source (origin
(method url-fetch)
(uri (string-append
@@ -49,11 +49,7 @@
version "-stable/libevent-" version "-stable.tar.gz"))
(sha256
(base32
- "1hhxnxlr0fsdv7bdmzsnhdz16fxf3jg2r6vyljcl3kj6pflcap4n"))
- (patches (search-patches "libevent-2.1-dns-tests.patch"
- ;; XXX: Try removing this for > 2.1.8.
- ;; https://github.com/libevent/libevent/issues/452
- "libevent-2.1-skip-failing-test.patch"))))
+ "1c25928gdv495clxk2v1d4gkr5py7ack4gx2n7d13frnld0syr78"))))
(build-system gnu-build-system)
(arguments
;; This skips some of the tests which fail on armhf and aarch64.