summaryrefslogtreecommitdiff
path: root/gnu/packages/libedit.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-15 07:28:38 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-15 07:28:38 +0100
commit85389321f023f3de2d454237d06d4014454da907 (patch)
tree425e1ba4b3c120ced7403664b7c483946ef95554 /gnu/packages/libedit.scm
parentc3d8bf3992d89df520a8eeb0df8d844fb781a308 (diff)
downloadguix-patches-85389321f023f3de2d454237d06d4014454da907.tar
guix-patches-85389321f023f3de2d454237d06d4014454da907.tar.gz
gnu: libedit: Update to 20170329-3.1.
* gnu/packages/libedit.scm (libedit): Update to 20170329-3.1. [arguments]: Remove deprecated ‘--enable-widec’ from #:configure-flags.
Diffstat (limited to 'gnu/packages/libedit.scm')
-rw-r--r--gnu/packages/libedit.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/libedit.scm b/gnu/packages/libedit.scm
index 7cb2de9be6..9f6f1d05ce 100644
--- a/gnu/packages/libedit.scm
+++ b/gnu/packages/libedit.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27,7 +28,7 @@
(define-public libedit
(package
(name "libedit")
- (version "20150325-3.1")
+ (version "20170329-3.1")
(source
(origin
(method url-fetch)
@@ -35,9 +36,8 @@
"/" name "-" version ".tar.gz"))
(sha256
(base32
- "1if8zi9h52m80ck796an28rrqfljk2n8cn25m3fl0prwz155x2n8"))))
+ "1gnlgl0x8g9ky59s70nriy5gv47676d1s4ypvbv8y11apl7xkwli"))))
(build-system gnu-build-system)
- (arguments `(#:configure-flags (list "--enable-widec")))
(inputs
`(("ncurses" ,ncurses)))
(home-page "https://thrysoee.dk/editline/")
@@ -48,5 +48,3 @@ library (libedit). This Berkeley-style licensed command line editor library
provides generic line editing, history, and tokenization functions, similar to
those found in GNU Readline.")
(license bsd-3)))
-
-;;; libedit.scm ends here