summaryrefslogtreecommitdiff
path: root/gnu/packages/libdaemon.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-04-08 15:26:57 +0200
committerLudovic Courtès <ludo@gnu.org>2020-04-11 19:22:26 +0200
commit5ea5d0512f912375358c339f81334454b03ef5a3 (patch)
treec41b87a5547f4282e06beacef54af0166f70c0c8 /gnu/packages/libdaemon.scm
parenta16022a7b889cefc86cb368c3475a7d0dd2edfb6 (diff)
downloadguix-patches-5ea5d0512f912375358c339f81334454b03ef5a3.tar
guix-patches-5ea5d0512f912375358c339f81334454b03ef5a3.tar.gz
gnu: libdaemon: Cross-build with --localstatedir=/var.
* gnu/packages/libdaemon.scm (libdaemon)[arguments]: Add "--localstatedir=/var" when (%current-target-system) is true.
Diffstat (limited to 'gnu/packages/libdaemon.scm')
-rw-r--r--gnu/packages/libdaemon.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/libdaemon.scm b/gnu/packages/libdaemon.scm
index a92892a6ae..e47d66cfa7 100644
--- a/gnu/packages/libdaemon.scm
+++ b/gnu/packages/libdaemon.scm
@@ -49,7 +49,15 @@
(if (%current-target-system)
;; The 'setpgrp' test cannot provide an answer when cross-compiling,
;; so provide the right one for glibc.
- `(#:configure-flags (list "ac_cv_func_setpgrp_void=yes"))
+ `(#:configure-flags (list "ac_cv_func_setpgrp_void=yes"
+
+ ;; TODO: Move this globally on the next
+ ;; rebuild cycle.
+ ;; Set a valid localstatedir for the
+ ;; benefit of the default
+ ;; 'daemon_pid_file_proc', used by the
+ ;; Hurd's console client.
+ "--localstatedir=/var"))
'()))
;; XXX: Stale URL, missing replacement. See <http://bugs.gnu.org/18639>.