summaryrefslogtreecommitdiff
path: root/gnu/packages/libcanberra.scm
diff options
context:
space:
mode:
authorFabian Harfert <fhmgufs@web.de>2016-02-07 14:41:25 +0100
committerAndreas Enge <andreas@enge.fr>2016-02-07 16:49:51 +0100
commit6366cef38da68dc2a8dca3c4070d852d54b69d7e (patch)
tree635c32ff6265ff00b135b80de96b31e63105af01 /gnu/packages/libcanberra.scm
parentfe476868df60426a09dea071882b972b591d5081 (diff)
downloadguix-patches-6366cef38da68dc2a8dca3c4070d852d54b69d7e.tar
guix-patches-6366cef38da68dc2a8dca3c4070d852d54b69d7e.tar.gz
gnu: Add libcanberra-gtk2.
* gnu/packages/libcanberra.scm (libcanberra/gtk+-2): New variable.
Diffstat (limited to 'gnu/packages/libcanberra.scm')
-rw-r--r--gnu/packages/libcanberra.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/libcanberra.scm b/gnu/packages/libcanberra.scm
index 3769e3fe21..50c0f80eed 100644
--- a/gnu/packages/libcanberra.scm
+++ b/gnu/packages/libcanberra.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016 Fabian Harfert <fhmgufs@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,6 +25,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build utils)
#:use-module (gnu packages autotools)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
@@ -96,6 +98,12 @@ GNOME. It comes with several backends (ALSA, PulseAudio, OSS, GStreamer,
null) and is designed to be portable.")
(license lgpl2.1+)))
+(define-public libcanberra/gtk+-2
+ (package (inherit libcanberra)
+ (name "libcanberra-gtk2")
+ (inputs `(,@(alist-delete "gtk+" (package-inputs libcanberra))
+ ("gtk+" ,gtk+-2)))))
+
(define-public sound-theme-freedesktop
(package
(name "sound-theme-freedesktop")