summaryrefslogtreecommitdiff
path: root/gnu/packages/libbsd.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-03-17 03:58:01 -0400
committerLeo Famulari <leo@famulari.name>2016-05-15 22:05:44 -0400
commitb7ab191ddd73f1e74294c98bb2f6a9697ea8a556 (patch)
tree52acd281208bc5b5762a3c013e88ebf897e30433 /gnu/packages/libbsd.scm
parentd8f3795622c892abd0ac023e40166ad4cd53646a (diff)
downloadguix-patches-b7ab191ddd73f1e74294c98bb2f6a9697ea8a556.tar
guix-patches-b7ab191ddd73f1e74294c98bb2f6a9697ea8a556.tar.gz
gnu: Add libbsd.
* gnu/packages/libbsd.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/libbsd.scm')
-rw-r--r--gnu/packages/libbsd.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/libbsd.scm b/gnu/packages/libbsd.scm
new file mode 100644
index 0000000000..3bfa2a3fec
--- /dev/null
+++ b/gnu/packages/libbsd.scm
@@ -0,0 +1,47 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages libbsd)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix download)
+ #:use-module (guix licenses)
+ #:use-module (guix packages))
+
+(define-public libbsd
+ (package
+ (name "libbsd")
+ (version "0.8.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://libbsd.freedesktop.org/releases/"
+ "libbsd-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1a1l7afchlvvj2zfi7ajcg26bbkh5i98y2v5h9j5p1px9m7n6jwk"))))
+ (build-system gnu-build-system)
+ (synopsis "Utility functions from BSD systems")
+ (description "This library provides useful functions commonly found on BSD
+systems, and lacking on others like GNU systems, thus making it easier to port
+projects with strong BSD origins, without needing to embed the same code over
+and over again on each project.")
+ (home-page "https://libbsd.freedesktop.org/wiki/")
+ ;; This package is a collection of third-party functions that were
+ ;; originally released under various non-copyleft licenses.
+ (license (list bsd-2 bsd-3 bsd-4 expat isc public-domain
+ (non-copyleft "file://COPYING"
+ "See COPYING in the distribution.")))))