summaryrefslogtreecommitdiff
path: root/gnu/packages/ld-wrapper.in
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2018-03-29 17:42:15 +0200
committerLudovic Courtès <ludovic.courtes@inria.fr>2018-03-29 17:58:16 +0200
commit6764538327a3ff24bc83ef731e9e74a9160981e2 (patch)
tree7d1f5416b82d21619f4437132ba86f9064e41182 /gnu/packages/ld-wrapper.in
parentc90fd42020ebb3b940cd73de01eec30f28883bbf (diff)
downloadguix-patches-6764538327a3ff24bc83ef731e9e74a9160981e2.tar
guix-patches-6764538327a3ff24bc83ef731e9e74a9160981e2.tar.gz
ld-wrapper: Make sure debugging output goes through.
* gnu/packages/ld-wrapper.in (ld-wrapper): Add call to 'force-output'.
Diffstat (limited to 'gnu/packages/ld-wrapper.in')
-rw-r--r--gnu/packages/ld-wrapper.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/ld-wrapper.in b/gnu/packages/ld-wrapper.in
index 82bd2196cf..24445eda12 100644
--- a/gnu/packages/ld-wrapper.in
+++ b/gnu/packages/ld-wrapper.in
@@ -15,7 +15,7 @@ main="(@ (gnu build-support ld-wrapper) ld-wrapper)"
exec @GUILE@ -c "(load-compiled \"@SELF@.go\") (apply $main (cdr (command-line)))" "$@"
!#
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -270,7 +270,8 @@ impure library ~s~%"
"ld-wrapper: libraries linked: ~s~%" libs)
(format (current-error-port)
"ld-wrapper: invoking `~a' with ~s~%"
- %real-ld args))
+ %real-ld args)
+ (force-output (current-error-port)))
(apply execl %real-ld (basename %real-ld) args)))
;;; ld-wrapper.scm ends here