summaryrefslogtreecommitdiff
path: root/gnu/packages/language.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-17 09:04:24 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-17 13:03:50 -0500
commit6afe59593b29c21fbd1e80ed589edad2b05bf828 (patch)
treeeb0b2313af8a0c6adbbe4dbfd8f580bc701ff3a2 /gnu/packages/language.scm
parentdf11e05241497e1e9e97178aaa93b9833acb2d65 (diff)
downloadguix-patches-6afe59593b29c21fbd1e80ed589edad2b05bf828.tar
guix-patches-6afe59593b29c21fbd1e80ed589edad2b05bf828.tar.gz
gnu: Add Lingua-Stem-It.
* gnu/packages/language.scm (perl-lingua-stem-it): New variable.
Diffstat (limited to 'gnu/packages/language.scm')
-rw-r--r--gnu/packages/language.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/language.scm b/gnu/packages/language.scm
index 2886fed966..ad222c785b 100644
--- a/gnu/packages/language.scm
+++ b/gnu/packages/language.scm
@@ -170,3 +170,22 @@ Moreira, V. and Huyck, C.")
(description "This module uses a modified version of the Porter Stemming
Algorithm to return a stemmed French word.")
(license (package-license perl))))
+
+(define-public perl-lingua-stem-it
+ (package
+ (name "perl-lingua-stem-it")
+ (version "0.02")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/A/AC/ACALPINI/"
+ "Lingua-Stem-It-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1207r183s5hlh4mfwa6p46vzm0dhvrs2dnss5s41a0gyfkxp7riq"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Lingua-Stem-It")
+ (synopsis "Porter's stemming algorithm for Italian")
+ (description "This module applies the Porter Stemming Algorithm to its
+parameters, returning the stemmed Italian word.")
+ (license (package-license perl))))