summaryrefslogtreecommitdiff
path: root/gnu/packages/language.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-01-04 14:51:26 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-01-04 22:38:12 +0100
commit1f6f0b6bca7788411e19ed4187a2ccc57ccc6186 (patch)
tree3c597bde1078afc1fa4a87d4ac04a106ab96752a /gnu/packages/language.scm
parentd946ede596d4f94cde6494c98f60077778627113 (diff)
downloadguix-patches-1f6f0b6bca7788411e19ed4187a2ccc57ccc6186.tar
guix-patches-1f6f0b6bca7788411e19ed4187a2ccc57ccc6186.tar.gz
gnu: Add link-grammar.
* gnu/packages/language.scm (link-grammar): New variable.
Diffstat (limited to 'gnu/packages/language.scm')
-rw-r--r--gnu/packages/language.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/language.scm b/gnu/packages/language.scm
index 1ed2483615..cec0ffa942 100644
--- a/gnu/packages/language.scm
+++ b/gnu/packages/language.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 ng0 <ng0@n0.is>
;;; Copyright © 2019 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -883,3 +884,27 @@ suitable for both the desktop and mobile devices.")
(("zinnia") "wagomu"))
#t))))))
(license lgpl2.1))) ; all files
+
+(define-public link-grammar
+ (package
+ (name "link-grammar")
+ (version "5.7.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.abisource.com/downloads/"
+ "link-grammar/" version
+ "/link-grammar-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0ak1v469k56v3511kxxkxvx1nw6zcxcl0f1kcvc82ffacqbr4y96"))))
+ (build-system gnu-build-system)
+ (home-page "https://www.abisource.com/projects/link-grammar/")
+ (synopsis "Link grammar parser")
+ (description "The Link Grammar Parser is a syntactic parser of English,
+Russian, Arabic and Persian (and other languages as well), based on Link
+Grammar, an original theory of syntax and morphology. Given a sentence, the
+system assigns to it a syntactic structure, which consists of a set of
+labelled links connecting pairs of words. The parser also produces a
+\"constituent\" (HPSG style phrase tree) representation of a sentence (showing
+noun phrases, verb phrases, etc.).")
+ (license bsd-3)))