summaryrefslogtreecommitdiff
path: root/gnu/packages/kodi.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-10 22:38:19 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-14 14:44:00 +0100
commitb165fe61dc6eaf96997973bee7d1bb98ca3e264b (patch)
treeaf6034d340d22f024496132d7cfcb162041fe33f /gnu/packages/kodi.scm
parent1f2e06014890e7ac94558f0595f2b699711cdde2 (diff)
downloadguix-patches-b165fe61dc6eaf96997973bee7d1bb98ca3e264b.tar
guix-patches-b165fe61dc6eaf96997973bee7d1bb98ca3e264b.tar.gz
gnu: Kodi: Add Wayland variant.
* gnu/packages/kodi.scm (kodi/wayland): New public variable.
Diffstat (limited to 'gnu/packages/kodi.scm')
-rw-r--r--gnu/packages/kodi.scm20
1 files changed, 19 insertions, 1 deletions
diff --git a/gnu/packages/kodi.scm b/gnu/packages/kodi.scm
index 776f9c970e..3929909d10 100644
--- a/gnu/packages/kodi.scm
+++ b/gnu/packages/kodi.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 David Thompson <davet@gnu.org>
-;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
@@ -43,6 +43,7 @@
#:use-module (gnu packages databases)
#:use-module (gnu packages documentation)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages fribidi)
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
@@ -462,6 +463,23 @@ plug-in system.")
license:bsd-3 ;misc, gtest
license:bsd-2)))) ;xbmc/freebsd
+(define-public kodi/wayland
+ (package/inherit kodi
+ (name "kodi-wayland")
+ (arguments
+ (substitute-keyword-arguments (package-arguments kodi)
+ ((#:configure-flags flags)
+ `(append '("-DCORE_PLATFORM_NAME=wayland"
+ "-DWAYLAND_RENDER_SYSTEM=gl")
+ ,flags))))
+ (inputs
+ `(("libinput" ,libinput)
+ ("libxkbcommon" ,libxkbcommon)
+ ("waylandpp" ,waylandpp)
+ ("waylandp-protocols" ,wayland-protocols)
+ ,@(package-inputs kodi)))
+ (synopsis "Kodi with Wayland rendering backend")))
+
(define-public kodi-cli
(let ((commit "104dc23b2a993c8e6db8c46f4f8bec24b146549b") ; Add support for
(revision "1")) ; `$HOME/.kodirc'.