summaryrefslogtreecommitdiff
path: root/gnu/packages/kodi.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-04-12 21:17:36 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-04-15 18:50:59 +0200
commit4ec1f82c636678858b1fe0ce6c755f66dc2dea77 (patch)
tree593e3e0dc02b2d79f54556da2c256d87eb2276c0 /gnu/packages/kodi.scm
parent2e58e05bb68d4b747882cfa2b460b132d456f54a (diff)
downloadguix-patches-4ec1f82c636678858b1fe0ce6c755f66dc2dea77.tar
guix-patches-4ec1f82c636678858b1fe0ce6c755f66dc2dea77.tar.gz
gnu: kodi: Update to 18.0_alpha-2-478d306.
* gnu/packages/kodi.scm (kodi): Update to 18.0_alpha-2-478d306. [arguments]<#:configure-flags>: Remove obsolete flag.
Diffstat (limited to 'gnu/packages/kodi.scm')
-rw-r--r--gnu/packages/kodi.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/kodi.scm b/gnu/packages/kodi.scm
index b5d86b5636..c59b78773d 100644
--- a/gnu/packages/kodi.scm
+++ b/gnu/packages/kodi.scm
@@ -239,8 +239,8 @@ generator library for C++.")
(define-public kodi
;; We package the git version because the current released
;; version was cut while the cmake transition was in turmoil.
- (let ((commit "ec5d53da72868ad37df8bc005452a6daaa20f20b")
- (revision "1"))
+ (let ((commit "478d3064a8c3d395e8afac314143561c7468ad87")
+ (revision "2"))
(package
(name "kodi")
(version (string-append "18.0_alpha-" revision "-" (string-take commit 7)))
@@ -252,7 +252,7 @@ generator library for C++.")
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "05f0bip0w784ya72plw3p2bism5m501q07si2xbmg03vhqsagjl5"))
+ "19vb1qkk0ffh0b03x6whwl598bylsby3813i79vgrq5cvr4pigfy"))
(snippet
'(begin
(use-modules (guix build utils))
@@ -263,7 +263,6 @@ generator library for C++.")
;; And these sources:
;; "tools/depend/native/JsonSchemaBuilder"
;; "tools/depend/native/TexturePacker"
- ;; "lib/UnrarXlib"
;; "lib/gtest"
;; "lib/cpluff"
;; "lib/libexif"
@@ -287,8 +286,7 @@ generator library for C++.")
(string-append "-Dlibdvdcss_URL="
(assoc-ref %build-inputs "libdvdcss-bootstrapped"))
(string-append "-DSYSTEM_LDFLAGS=-Wl,-rpath="
- (assoc-ref %build-inputs "curl") "/lib")
- "-DENABLE_NONFREE=OFF")
+ (assoc-ref %build-inputs "curl") "/lib"))
#:phases
(modify-phases %standard-phases
;; The build system tries to bootstrap these bundled components