summaryrefslogtreecommitdiff
path: root/gnu/packages/kerberos.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-01-18 09:57:43 +0100
committerLudovic Courtès <ludo@gnu.org>2017-01-19 00:11:15 +0100
commit89e34644d94860fafc053b759961ba8b55a6c77c (patch)
tree8eb6e2348e25d6fe08499c3337254e14c92a1a79 /gnu/packages/kerberos.scm
parent877c6163fad47c068826123614848f9500f39af1 (diff)
downloadguix-patches-89e34644d94860fafc053b759961ba8b55a6c77c.tar
guix-patches-89e34644d94860fafc053b759961ba8b55a6c77c.tar.gz
gnu: Move Kerberos implemetations to (gnu packages kerberos).
* gnu/packages/mit-krb5.scm: Remove. * gnu/packages/shishi.scm: Remove. * gnu/packages/kerberos.scm: New file, from the concatenation of these two. * gnu/local.mk (GNU_SYSTEM_MODULES): Adjust accordingly. * gnu/packages/admin.scm, gnu/packages/cyrus-sasl.scm, gnu/packages/gnome.scm, gnu/packages/gnuzilla.scm, gnu/packages/gsasl.scm, gnu/packages/java.scm, gnu/packages/networking.scm, gnu/packages/nfs.scm, gnu/packages/onc-rpc.scm, gnu/packages/ssh.scm, gnu/packages/web.scm: Adjust accordingly.
Diffstat (limited to 'gnu/packages/kerberos.scm')
-rw-r--r--gnu/packages/kerberos.scm131
1 files changed, 131 insertions, 0 deletions
diff --git a/gnu/packages/kerberos.scm b/gnu/packages/kerberos.scm
new file mode 100644
index 0000000000..3178784f92
--- /dev/null
+++ b/gnu/packages/kerberos.scm
@@ -0,0 +1,131 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2012, 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2012, 2013 Nikita Karetnikov <nikita@karetnikov.org>
+;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages kerberos)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages bison)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages gnupg)
+ #:use-module (gnu packages libidn)
+ #:use-module (gnu packages linux)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages tls)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix utils)
+ #:use-module (guix build-system gnu))
+
+(define-public mit-krb5
+ (package
+ (name "mit-krb5")
+ (version "1.14.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://web.mit.edu/kerberos/dist/krb5/"
+ (version-major+minor version)
+ "/krb5-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1jgjiyh1sp72lkxvk437lz5hzcibvw99jc4ihzfz03fg43aj0ind"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("bison" ,bison)
+ ("perl" ,perl)))
+ (arguments
+ `(;; Work around "No rule to make target '../../include/gssapi/gssapi.h',
+ ;; needed by 'authgss_prot.so'."
+ #:parallel-build? #f
+
+ ;; Likewise with tests.
+ #:parallel-tests? #f
+
+ ;; XXX: On 32-bit systems, 'kdb5_util' hangs on an fcntl/F_SETLKW call
+ ;; while running the tests in 'src/tests'.
+ #:tests? ,(string=? (%current-system) "x86_64-linux")
+
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'enter-source-directory
+ (lambda _
+ (chdir "src")
+ #t))
+ (add-before 'check 'pre-check
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((perl (assoc-ref inputs "perl")))
+ (substitute* "plugins/kdb/db2/libdb2/test/run.test"
+ (("/bin/cat") (string-append perl "/bin/perl"))
+ (("D/bin/sh") (string-append "D" (which "bash")))
+ (("bindir=/bin/.") (string-append "bindir=" perl "/bin"))))
+
+ ;; avoid service names since /etc/services is unavailable
+ (substitute* "tests/resolve/Makefile"
+ (("-p telnet") "-p 23"))
+ #t)))))
+ (synopsis "MIT Kerberos 5")
+ (description
+ "Massachusetts Institute of Technology implementation of Kerberos.
+Kerberos is a network authentication protocol designed to provide strong
+authentication for client/server applications by using secret-key
+cryptography.")
+ (license (license:non-copyleft "file://NOTICE"
+ "See NOTICE in the distribution."))
+ (home-page "http://web.mit.edu/kerberos/")))
+
+(define-public shishi
+ (package
+ (name "shishi")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/shishi/shishi-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "032qf72cpjdfffq1yq54gz3ahgqf2ijca4vl31sfabmjzq9q370d"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gnutls" ,gnutls)
+ ("libidn" ,libidn)
+ ("linux-pam" ,linux-pam-1.2)
+ ("zlib" ,zlib)
+ ;; libgcrypt 1.6 fails because of the following test:
+ ;; #include <gcrypt.h>
+ ;; /* GCRY_MODULE_ID_USER was added in 1.4.4 and gc-libgcrypt.c
+ ;; will fail on startup if we don't have 1.4.4 or later, so
+ ;; test for it early. */
+ ;; #if !defined GCRY_MODULE_ID_USER
+ ;; error too old libgcrypt
+ ;; #endif
+ ("libgcrypt" ,libgcrypt-1.5)
+ ("libtasn1" ,libtasn1)))
+ (home-page "http://www.gnu.org/software/shishi/")
+ (synopsis "Implementation of the Kerberos 5 network security system")
+ (description
+ "GNU Shishi is a free implementation of the Kerberos 5 network security
+system. It is used to allow non-secure network nodes to communicate in a
+secure manner through client-server mutual authentication via tickets.")
+ (license license:gpl3+)))